summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-06 13:53:15 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-06 13:53:30 +0200
commit75c1e5775adf387c9f56c5eb37f5c4114b6cef46 (patch)
treed7dd04964a5634bfdfb14444c5f7341f2e7bf2ec /sci-chemistry
parentapp-text/zotero-bin: drop 6.0.8 (diff)
downloadgentoo-75c1e5775adf387c9f56c5eb37f5c4114b6cef46.tar.gz
gentoo-75c1e5775adf387c9f56c5eb37f5c4114b6cef46.tar.bz2
gentoo-75c1e5775adf387c9f56c5eb37f5c4114b6cef46.zip
sci-chemistry/propka: add 3.4.0
Closes: https://bugs.gentoo.org/832251 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/propka/Manifest1
-rw-r--r--sci-chemistry/propka/metadata.xml1
-rw-r--r--sci-chemistry/propka/propka-3.4.0.ebuild28
3 files changed, 30 insertions, 0 deletions
diff --git a/sci-chemistry/propka/Manifest b/sci-chemistry/propka/Manifest
index 4141de909047..3ed3d129ddbf 100644
--- a/sci-chemistry/propka/Manifest
+++ b/sci-chemistry/propka/Manifest
@@ -1 +1,2 @@
DIST propka-3.2.0.tar.gz 73746 BLAKE2B f79e493d5a195b81dc5d11cc21b9ab16c8d1fa48f15f7e23e2b2936dfb8634fdb00c7838b8dbdb4a68726dab0f16e54522ad71d71b3273ac93c03a737ae06f04 SHA512 98f2240b28b33bab94cdbe9392062bb7f6b87e75b94c2af91e178f874a74d210601161ebc835c4d751b89d37b32348fdfb096e28cbf8e9237b3f472d3fb6b4fc
+DIST propka-3.4.0.gh.tar.gz 363641 BLAKE2B 87f495ba69028593cf3ebf98ed33da0944f7a3833f2d08cae4f0a0b5cbe2f3a67e9812685b896a7d89c88ba25653861f135dbac53dc6df7af426a290bacb3d22 SHA512 2ce431c66374d0692acb7504661caa870ab6460ace3a6478f88c1d46a7bfcd82c748bf153a1ce2ea6d1611bc4bbf2351c4f5149f4578e5f8a9f9ec8385298fe9
diff --git a/sci-chemistry/propka/metadata.xml b/sci-chemistry/propka/metadata.xml
index 03810a218076..5153791d2361 100644
--- a/sci-chemistry/propka/metadata.xml
+++ b/sci-chemistry/propka/metadata.xml
@@ -9,4 +9,5 @@
<remote-id type="pypi">propka</remote-id>
<remote-id type="github">jensengroup/propka</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>
diff --git a/sci-chemistry/propka/propka-3.4.0.ebuild b/sci-chemistry/propka/propka-3.4.0.ebuild
new file mode 100644
index 000000000000..81b20fbee2e0
--- /dev/null
+++ b/sci-chemistry/propka/propka-3.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="pKa-value prediction of ionizable groups in protein and protein-ligand complexes"
+HOMEPAGE="https://github.com/jensengroup/propka"
+SRC_URI="https://github.com/jensengroup/propka/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the tests
+ sed -e "/exclude/s:scripts:\', \'tests:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}