summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-18 17:05:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-18 17:06:40 +0200
commit7bec1238b70d17e71a5425726aee7e44b91db125 (patch)
tree0376c07d187d0a12b1203b24d7fea79cac470c9e /sci-chemistry
parentmedia-sound/patchage: needs libfmt < 9 (diff)
downloadgentoo-7bec1238b70d17e71a5425726aee7e44b91db125.tar.gz
gentoo-7bec1238b70d17e71a5425726aee7e44b91db125.tar.bz2
gentoo-7bec1238b70d17e71a5425726aee7e44b91db125.zip
sci-chemistry/chemex: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/chemex/chemex-2021.4.0_p6-r1.ebuild (renamed from sci-chemistry/chemex/chemex-2021.4.0_p6.ebuild)14
-rw-r--r--sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild (renamed from sci-chemistry/chemex/chemex-2022.0.1.ebuild)12
2 files changed, 7 insertions, 19 deletions
diff --git a/sci-chemistry/chemex/chemex-2021.4.0_p6.ebuild b/sci-chemistry/chemex/chemex-2021.4.0_p6-r1.ebuild
index 62c958f646d3..3b5a05f349d5 100644
--- a/sci-chemistry/chemex/chemex-2021.4.0_p6.ebuild
+++ b/sci-chemistry/chemex/chemex-2021.4.0_p6-r1.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
inherit distutils-r1
DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
HOMEPAGE="https://github.com/gbouvignies/chemex"
SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
SLOT="0"
LICENSE="BSD"
@@ -28,7 +30,6 @@ RDEPEND="
>=dev-python/lmfit-1.0.3[${PYTHON_USEDEP}]
>=dev-python/matplotlib-3.4.3[${PYTHON_USEDEP}]
>=dev-python/numpy-1.21.2[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
>=dev-python/scipy-1.7.0[${PYTHON_USEDEP}]
>=dev-python/tomlkit-0.7.2[${PYTHON_USEDEP}]
>=dev-python/tqdm-4.61.1[${PYTHON_USEDEP}]
@@ -37,10 +38,3 @@ RDEPEND="
DEPEND="${RDEPEND}"
distutils_enable_tests pytest
-
-S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
-
-src_prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
- distutils-r1_src_prepare
-}
diff --git a/sci-chemistry/chemex/chemex-2022.0.1.ebuild b/sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild
index 073cdcbe2dac..9abd2a6493fb 100644
--- a/sci-chemistry/chemex/chemex-2022.0.1.ebuild
+++ b/sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild
@@ -2,15 +2,17 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
inherit distutils-r1
DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
HOMEPAGE="https://github.com/gbouvignies/chemex"
SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
SLOT="0"
LICENSE="BSD"
@@ -31,7 +33,6 @@ RDEPEND="
>=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
>=dev-python/rapidfuzz-2.8.0[${PYTHON_USEDEP}]
>=dev-python/rich-12.5.1[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
>=dev-python/scipy-1.9.1[${PYTHON_USEDEP}]
>=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
')
@@ -39,10 +40,3 @@ RDEPEND="
DEPEND="${RDEPEND}"
distutils_enable_tests pytest
-
-S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
-
-src_prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
- distutils-r1_src_prepare
-}