summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-28 21:29:54 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:44 -0500
commit9f05f425404b697ae4a3dab62135a4f4c0ec201a (patch)
tree742da55cda0d124e82a43401ea4dd7a6ab833099 /sci-libs/klu
parentsci-libs/ldl: new version 2.2.6. (diff)
downloadgentoo-9f05f425404b697ae4a3dab62135a4f4c0ec201a.tar.gz
gentoo-9f05f425404b697ae4a3dab62135a4f4c0ec201a.tar.bz2
gentoo-9f05f425404b697ae4a3dab62135a4f4c0ec201a.zip
sci-libs/klu: new version 1.3.9.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/klu')
-rw-r--r--sci-libs/klu/Manifest1
-rw-r--r--sci-libs/klu/klu-1.3.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/klu/Manifest b/sci-libs/klu/Manifest
index a9fc6f97819e..1a5d0c913138 100644
--- a/sci-libs/klu/Manifest
+++ b/sci-libs/klu/Manifest
@@ -1 +1,2 @@
DIST klu-1.2.1.tar.bz2 612428 BLAKE2B 807bfc56deb5c4cbefd2f6c118cd8e929ba9b02d9b88e8eee8b9443991f16a2a3e9b4e1fa888b2b6e450aeda9fc4d12d6a5480f9f25bf366312f57cd8f380af0 SHA512 2837ade61596b5e738d0dd16a5486fd2b0089ec9ddeae4fa3b2c3671de6637c7cf2d55e44c0103c9393caa3f046039a76d9abc5b8094d236523db0c58cc58b70
+DIST klu-1.3.9.tar.bz2 635596 BLAKE2B 6c6c84cf1b30e78cbaaee6bebed21c806d1672bee5f7ea061e7ef057ff56fd456e8517ca2ff1018a14ebcbc8f96b9e87989e22d8996817394666e6d8d2d727dd SHA512 b7fd862fe8443596758c27f9c918e367b3b3816340836e74cf8d97a2e755fbe07d133778eea3d054bc70243fa15c2bd71f4fd90c1179879661ba2d624b8f0706
diff --git a/sci-libs/klu/klu-1.3.9.ebuild b/sci-libs/klu/klu-1.3.9.ebuild
new file mode 100644
index 000000000000..14645153cd81
--- /dev/null
+++ b/sci-libs/klu/klu-1.3.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Sparse LU factorization for circuit simulation"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND="
+ >=sci-libs/amd-2.4
+ >=sci-libs/btf-1.2
+ >=sci-libs/colamd-2.9"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with doc)
+}