summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-07-20 17:37:23 +0000
committerSam James <sam@gentoo.org>2024-09-09 19:15:18 +0100
commit1d606e6db2981df0541da76f554142dab10058df (patch)
tree318b45e16e2f3d29cfd7bd86478c9cf4f1cf8689 /sci-libs
parentsci-libs/rocRAND: strip unsupported flags for potentially switched compiler (diff)
downloadgentoo-1d606e6db2981df0541da76f554142dab10058df.tar.gz
gentoo-1d606e6db2981df0541da76f554142dab10058df.tar.bz2
gentoo-1d606e6db2981df0541da76f554142dab10058df.zip
sci-libs/rocSOLVER: strip unsupported flags for potentially switched compiler
Bug: https://bugs.gentoo.org/936099 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocSOLVER/rocSOLVER-6.1.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/rocSOLVER/rocSOLVER-6.1.1.ebuild b/sci-libs/rocSOLVER/rocSOLVER-6.1.1.ebuild
index 4fe2bbbdaca1..c2fdccf5764b 100644
--- a/sci-libs/rocSOLVER/rocSOLVER-6.1.1.ebuild
+++ b/sci-libs/rocSOLVER/rocSOLVER-6.1.1.ebuild
@@ -32,6 +32,8 @@ BDEPEND="test? ( dev-cpp/gtest
RESTRICT="!test? ( test )"
src_configure() {
+ rocm_use_hipcc
+
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
@@ -43,7 +45,7 @@ src_configure() {
-DBUILD_CLIENTS_BENCHMARKS=$(usex benchmark ON OFF)
)
- CXX=hipcc cmake_src_configure
+ cmake_src_configure
}
src_test() {