summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-12 11:19:37 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-12 11:19:37 +0100
commitb233842a5305ee457f09e2dd396b76e0d39dea26 (patch)
tree167caf916e58086faf19dee5433bf87766248aa6 /sci-libs
parentnet-fs/docker-volume-netshare: treeclean (diff)
downloadgentoo-b233842a5305ee457f09e2dd396b76e0d39dea26.tar.gz
gentoo-b233842a5305ee457f09e2dd396b76e0d39dea26.tar.bz2
gentoo-b233842a5305ee457f09e2dd396b76e0d39dea26.zip
sci-libs/inchi: Port to EAPI 8
Closes: https://bugs.gentoo.org/828699 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/inchi/files/inchi-1.03-shared.patch5
-rw-r--r--sci-libs/inchi/files/inchi-1.04-static.patch26
-rw-r--r--sci-libs/inchi/inchi-1.04-r1.ebuild (renamed from sci-libs/inchi/inchi-1.04.ebuild)37
3 files changed, 14 insertions, 54 deletions
diff --git a/sci-libs/inchi/files/inchi-1.03-shared.patch b/sci-libs/inchi/files/inchi-1.03-shared.patch
index 6f4619d86bd9..6a47ce99c294 100644
--- a/sci-libs/inchi/files/inchi-1.03-shared.patch
+++ b/sci-libs/inchi/files/inchi-1.03-shared.patch
@@ -1,8 +1,3 @@
- INCHI_API/gcc_so_makefile/makefile | 4 +++-
- 1 files changed, 3 insertions(+), 1 deletions(-)
-
-diff --git a/INCHI_API/gcc_so_makefile/makefile b/INCHI_API/gcc_so_makefile/makefile
-index dd8e53c..cd617ad 100644
--- a/INCHI_API/gcc_so_makefile/makefile
+++ b/INCHI_API/gcc_so_makefile/makefile
@@ -213,9 +213,11 @@ $(INCHI_LIB_PATHNAME).so$(VERSION): $(INCHI_LIB_OBJS)
diff --git a/sci-libs/inchi/files/inchi-1.04-static.patch b/sci-libs/inchi/files/inchi-1.04-static.patch
deleted file mode 100644
index a367c153824a..000000000000
--- a/sci-libs/inchi/files/inchi-1.04-static.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- INCHI_API/gcc_so_makefile/makefile 2012-05-13 14:52:53.587632989 +0300
-+++ INCHI_API/gcc_so_makefile/makefile 2012-05-13 14:52:11.668635419 +0300
-@@ -209,6 +209,14 @@
-
- else
-
-+ifdef STATIC
-+
-+libinchi.a: $(INCHI_LIB_OBJS)
-+ $(AR) rcs $(INCHI_LIB_PATHNAME).a $(INCHI_LIB_OBJS)
-+ $(RANLIB) $(INCHI_LIB_PATHNAME).a
-+
-+else
-+
- $(INCHI_LIB_PATHNAME).so$(VERSION): $(INCHI_LIB_OBJS)
- $(SHARED_LINK) $(SHARED_LINK_PARM) -o \
- $(INCHI_LIB_PATHNAME).so$(VERSION) \
-@@ -219,6 +226,8 @@
-
- endif
-
-+endif
-+
- # === InChI Library compile rule =========
-
- %.o: $(P_LIBR)%.c
diff --git a/sci-libs/inchi/inchi-1.04.ebuild b/sci-libs/inchi/inchi-1.04-r1.ebuild
index c41a1e5ee2dc..5a19ed1854a7 100644
--- a/sci-libs/inchi/inchi-1.04.ebuild
+++ b/sci-libs/inchi/inchi-1.04-r1.ebuild
@@ -1,30 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Program and library for generating standard and non-standard InChI and InChIKeys"
HOMEPAGE="http://www.iupac.org/inchi/"
SRC_URI="
http://www.inchi-trust.org/sites/default/files/inchi-${PV}/INCHI-1-API.ZIP -> ${P}.zip
doc? ( http://www.inchi-trust.org/sites/default/files/inchi-${PV}/INCHI-1-DOC.ZIP -> ${P}-doc.zip )"
+S="${WORKDIR}"/INCHI-1-API
LICENSE="IUPAC-InChi"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+IUSE="doc"
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
-S="${WORKDIR}"/INCHI-1-API
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.03-shared.patch
+)
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.03-shared.patch \
- "${FILESDIR}"/${PN}-1.04-static.patch
+src_configure() {
tc-export AR RANLIB
}
@@ -43,31 +42,23 @@ src_compile() {
ISLINUX=1
)
for dir in INCHI/gcc/inchi-1 INCHI_API/gcc_so_makefile; do
- pushd ${dir} > /dev/null
+ pushd ${dir} > /dev/null || die
emake \
"${common_opts[@]}"
- popd > /dev/null
+ popd > /dev/null || die
done
- if use static-libs ; then
- pushd INCHI_API/gcc_so_makefile > /dev/null
- emake libinchi.a \
- "${common_opts[@]}" \
- STATIC=1
- popd > /dev/null
- fi
}
src_install() {
dodoc readme*.txt
if use doc ; then
- cd "${WORKDIR}/INCHI-1-DOC/"
+ cd "${WORKDIR}"/INCHI-1-DOC || die
docinto doc
dodoc *.pdf readme.txt
fi
dobin "${S}"/INCHI/gcc/inchi-1/inchi-1
- cd "${S}/INCHI_API/gcc_so_makefile/result" || die
+ cd "${S}"/INCHI_API/gcc_so_makefile/result || die
rm *gz || die
dolib.so lib*so*
- use static-libs && dolib.a lib*a
doheader ../../inchi_main/inchi_api.h
}