summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-28 15:41:53 +0100
committerSam James <sam@gentoo.org>2024-09-28 15:43:06 +0100
commitbf702b6cee0133e094b50378336326b6bff4926b (patch)
tree89ef31c374316a5fe6f7b2151547e2833aa161a3 /sci-libs
parentdev-python/pycairo: Stabilize 1.27.0 ppc, #940432 (diff)
downloadgentoo-bf702b6cee0133e094b50378336326b6bff4926b.tar.gz
gentoo-bf702b6cee0133e094b50378336326b6bff4926b.tar.bz2
gentoo-bf702b6cee0133e094b50378336326b6bff4926b.zip
sci-libs/nlopt: fix pkg_setup w/ USE=-guile
Like in 20c679298cd29c57dba3dce93339b0a1780284e5. This seems to be the only other such case in-tree. Note that fortran-2_pkg_setup is fine to call unconditionally because it checks itself if it should be used if FORTRAN_OPTIONAL is set. Bug: https://bugs.gentoo.org/940441 Fixes: 01f1676c357e17cfde5abb0ccca96766e69bbe6f Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/nlopt-2.7.1-r100.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sci-libs/nlopt/nlopt-2.7.1-r100.ebuild b/sci-libs/nlopt/nlopt-2.7.1-r100.ebuild
index 55bc5573894b..385cdb5a674d 100644
--- a/sci-libs/nlopt/nlopt-2.7.1-r100.ebuild
+++ b/sci-libs/nlopt/nlopt-2.7.1-r100.ebuild
@@ -31,6 +31,11 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="python? ( dev-lang/swig )"
+pkg_setup() {
+ use guile && guile-single_pkg_setup
+ fortran-2_pkg_setup
+}
+
src_prepare() {
cmake_src_prepare