summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-05-29 22:00:44 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-05-29 22:00:44 +0700
commit06521b3caafc9731504017feb8957ec9e5db47ed (patch)
tree92cc36b416c09cea87c92fb32ba0949392fd4fc4 /sci-mathematics/wxmaxima
parentxfce-extra/xfce4-whiskermenu-plugin: Stabilize 2.7.3 amd64, #907370 (diff)
downloadgentoo-06521b3caafc9731504017feb8957ec9e5db47ed.tar.gz
gentoo-06521b3caafc9731504017feb8957ec9e5db47ed.tar.bz2
gentoo-06521b3caafc9731504017feb8957ec9e5db47ed.zip
sci-mathematics/wxmaxima: bump to 23.05.1
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-23.05.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 43675e9c21e5..9eeef63afbcf 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-20.12.2.tar.gz 16262617 BLAKE2B 2f9f910f565158b2011f014d96747498c6286a95bdb69f9b6b2f82a37a569e8a02abbae5cbb9ae2ac1e78d0b976487666794b267c1c40c1245df08c752486403 SHA512 1c3e3f68a2fa2cd798dfb05c52e7ddf3193a15cb45282553c280914bd524d463ad27acc89898cb4a292ff236699d1ec2abb70d83fa52cb126123ab8e2fcd5ceb
DIST wxmaxima-23.04.1.tar.gz 22060726 BLAKE2B 77583c2461f7c32ac53ad2890d1e7d07a9fc2dd0caa07a1fcdd7c62d39ec63c50173542c74ce2d21093ce724d1777b76e7789f8a5363ff20406d52177c86a016 SHA512 9846c11cbeec8411170e0d55916187cc77274e2758726784bcb5540d55f712b5a557562de0c37dac0c7ef119d43570bd33efc33252fc5359627e527d668580a4
DIST wxmaxima-23.05.0.tar.gz 16216267 BLAKE2B 2f735a154d8f892799a18384bc1dc1bda22ce0d23cfd6f382971fce468e69f83926992bad111824c94a0c11a91107e8811567abec51035089613f057ab0ee8f8 SHA512 068e8ca93150b9b4649cbc57e375d526060095da4fff0a7217451febd478aff3be78c86d72d60fcee530a6c2d78c2b5e8c41cb3b5b85c9858813be79e18a83d5
+DIST wxmaxima-23.05.1.tar.gz 16220058 BLAKE2B a680a562c92ac400c2e3e377e9f6aa387a259b3bfc9d533bba2f2fcc4c5abfca78c578935273932cbb4be6aa04c29c0316582472f212b0868cba2bfb0081234f SHA512 a36cf3207058065dbe68b8a75b7a97ab0ab827c9097f90a67af1c436703a22bff6978fbf173e0806e40d01270d97def1137de9af7d2501e96faca475d474c5af
diff --git a/sci-mathematics/wxmaxima/wxmaxima-23.05.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-23.05.1.ebuild
new file mode 100644
index 000000000000..eb18fbdaf093
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-23.05.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}