summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-02-14 21:39:57 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-02-14 21:39:57 +0700
commit6cc3a86fca9c65a94c0c8fb2cb8cf73fd7660e54 (patch)
tree1a37587c412c936019a5153a6cb8802b9b8c053d /sci-mathematics/wxmaxima
parent*/*: update maintainer info (diff)
downloadgentoo-6cc3a86fca9c65a94c0c8fb2cb8cf73fd7660e54.tar.gz
gentoo-6cc3a86fca9c65a94c0c8fb2cb8cf73fd7660e54.tar.bz2
gentoo-6cc3a86fca9c65a94c0c8fb2cb8cf73fd7660e54.zip
sci-mathematics/wxmaxima: bump to 24.02.1
Closes: https://bugs.gentoo.org/924160 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index f1eb8547b536..d95b669de0a8 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -2,3 +2,4 @@ DIST wxmaxima-23.07.0.tar.gz 16427247 BLAKE2B c754e476adcf71b2074e5d20edc14ac0d8
DIST wxmaxima-23.10.0.tar.gz 16466027 BLAKE2B 496765bfe55efb168396530eb3c44ef727f0398bf30a32e9a869c48572f0b53b6d851a7d8aa421199c071791efec37dece6cc23901826c62ca7ab6715a27b0cc SHA512 4055595f8e294726d2731da4a926844d3ad25561bb7d392c0ef08eb9322bc7e454edb6ae137eb7b8c2be53aba2f36abb0a0b32e03af4cc9a517130fd5466a1fb
DIST wxmaxima-23.12.0.tar.gz 16491009 BLAKE2B 1df61e6571302b9ae693af77b48c60d3799f036f2e5214ef5f003e4b9f20fa66a37ed10f52b35ac05e114e9a53afda761262bdf55dde86020687f69f5458ec78 SHA512 f0b8f17cd9e367fbd95dd9304926742b05ab6d04da07aed54b183d5fa97a5d0054481626182874daf54011bd3f2d3f4b467b1daf600d003976483331578eed89
DIST wxmaxima-24.02.0.tar.gz 16485036 BLAKE2B 7994f126f975ae6ed801f6856cbf918302d67729d24a9057a709986c3c5e56c9d48793e32421da6c208a6ebcd571bac952175d81a931d3be264ddc2b336bfb52 SHA512 a64cf2c1024232df89d45c0a45eb59c62eeddd28a4bfb14765c1c7eca90fb3ce01fb681f7e65140243909afd34c95d399906afae1d11603f35f452e8831ec9d1
+DIST wxmaxima-24.02.1.tar.gz 17048739 BLAKE2B 207365951d911d160c55c9e10308b2645129082d0ce72c1b4a2ad8e6d5d0469beb4f8faeb8c48965bfa1c4df8f4ecb7ace8f0f9a5193f0bbc4d002437bc8fe77 SHA512 f16b4c974e0bb3d2454465498fae09d3995278a4ac1f1f8c756716bcf5e560925c115259e6540b57a08910b65e897fba896be7f527ed80ba4e3cb7c4863ca6cc
diff --git a/sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild
new file mode 100644
index 000000000000..3fbeb1a253b0
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit?]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ -DWXM_DISABLE_WEBVIEW=$(usex webkit OFF ON)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}