summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-05-30 21:12:50 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-05-30 21:12:50 +0700
commite57dfb8ea3b13da1b5983546a920b99ac82afff7 (patch)
tree5ae77147fe129bde4af983a35e63c8644adb9c1d /sci-mathematics/wxmaxima
parentsci-mathematics/wxmaxima: remove old version (diff)
downloadgentoo-e57dfb8ea3b13da1b5983546a920b99ac82afff7.tar.gz
gentoo-e57dfb8ea3b13da1b5983546a920b99ac82afff7.tar.bz2
gentoo-e57dfb8ea3b13da1b5983546a920b99ac82afff7.zip
sci-mathematics/wxmaxima: commit 24.02.1 back
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 256bed9f9a32..d28fc73875c3 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,2 +1,3 @@
+DIST wxmaxima-24.02.1.tar.gz 17048739 BLAKE2B 207365951d911d160c55c9e10308b2645129082d0ce72c1b4a2ad8e6d5d0469beb4f8faeb8c48965bfa1c4df8f4ecb7ace8f0f9a5193f0bbc4d002437bc8fe77 SHA512 f16b4c974e0bb3d2454465498fae09d3995278a4ac1f1f8c756716bcf5e560925c115259e6540b57a08910b65e897fba896be7f527ed80ba4e3cb7c4863ca6cc
DIST wxmaxima-24.02.2.tar.gz 16844499 BLAKE2B b7edd01771450ba4c668f45a6ee2fae9b470e6da90a383d24b3f473a2fea744de5bdb4c6702b23d5fd9abb869ba1e917016da485c064311c1167adec853b3fdd SHA512 012becedd9668de042596bbe81628962e91d5d0dba876d7195dc3bf00075ac7cc680e8dfa6fd5613077ae01bd5532eb2dc5401e6a1f0603612fef5dc0ed014cf
DIST wxmaxima-24.05.0.tar.gz 16824007 BLAKE2B b6d6db89c20b76713c19b810d24571d6ded3937573ef72f8c8a73cdf870e164da6916b602f4e6970e6094eb1c4e575de62f06a20f14ee75679c70cff6a6629cb SHA512 62a5911220fc1a9403ca3af11110b9043cffcf0b3a1ef6e6a87f74e63de6a00e2bf809db1a05fe2b5bc40da155746c05d68ff247c424c63a6bd6724b5fe12be9
diff --git a/sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild
new file mode 100644
index 000000000000..972c1e5f188b
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-24.02.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit?]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ -DWXM_DISABLE_WEBVIEW=$(usex webkit OFF ON)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}