summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-17 22:21:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-17 22:45:10 +0200
commit2700367b2e05b7d45e0400d13a6d1256206a2300 (patch)
treea4db3462968ef2f4bdf57125ea3029df4bf8bdc1 /sci-mathematics
parentdev-lang/eisl: bump to 2.93 (diff)
downloadgentoo-2700367b2e05b7d45e0400d13a6d1256206a2300.tar.gz
gentoo-2700367b2e05b7d45e0400d13a6d1256206a2300.tar.bz2
gentoo-2700367b2e05b7d45e0400d13a6d1256206a2300.zip
sci-mathematics/lean: bump to 3.51.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/lean/Manifest1
-rw-r--r--sci-mathematics/lean/lean-3.51.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index 38d4ce5c1bcf..065df8cd90b3 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -1,2 +1,3 @@
DIST lean-3.49.0.tar.gz 1918154 BLAKE2B 9f9973d00d2d5d5b7d26d50117c27754feb5132e88decd55859432a384dac2897184dcf8d841ad0034854657ac25e462dc69cdbe1cf2040787d108bb7e1370f4 SHA512 b4672843c2e923da8d56b91c14966fc2ec66c573564d68db9c52f9b40f2c97d82497f2ef6424b023c4ae50f6f0c11674e2d79053844ea669d226d0fe24077ade
DIST lean-3.50.3.tar.gz 1918462 BLAKE2B f8cb3857989e4966c12a9b4f4a13403ceab0ae9d33ddf81970ef886fb1f46bfd14bfc15aea498ea360cc801224c60489f0ce3b33fe10bead4dcbf3f6a06eee93 SHA512 849b9e8854585ce119f87e8bea655bcb834f1f986bccbf5ffa148fd4a1aae2030b6be938adbf377f0076361a3d9338802e1af8965f01b9c4d2a0517be330beef
+DIST lean-3.51.0.tar.gz 1918905 BLAKE2B 83131417011d89846084608fc9b6b5b8254584da63b2e2d7626064a170c3bd3780973483ce60afc49713df840e150c4ed92951bfd7fbdeb520791e58164313cd SHA512 712c5520d298cf7098f5e5d787ba91096d73ba08a15581f4478836c7790679950a1a0b0d7d9c876b1557ae7dc56b10430ac1b4227b5d30ac1ad398e196c2fb11
diff --git a/sci-mathematics/lean/lean-3.51.0.ebuild b/sci-mathematics/lean/lean-3.51.0.ebuild
new file mode 100644
index 000000000000..72a23985077c
--- /dev/null
+++ b/sci-mathematics/lean/lean-3.51.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CMAKE_IN_SOURCE_BUILD="ON"
+
+inherit flag-o-matic cmake readme.gentoo-r1
+
+DESCRIPTION="The Lean Theorem Prover"
+HOMEPAGE="https://leanprover-community.github.io/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
+else
+ SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${S}/src"
+
+LICENSE="Apache-2.0"
+SLOT="0/${MAJOR}"
+IUSE="debug +threads"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.50.3-gcc-13.patch
+ "${FILESDIR}"/${PN}-CMakeLists-fix_flags.patch
+)
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug; then
+ CMAKE_BUILD_TYPE="Debug"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+
+ filter-lto
+
+ local -a mycmakeargs=(
+ -DALPHA=ON
+ -DAUTO_THREAD_FINALIZATION=ON
+ -DJSON=ON # bug 833900
+ -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
+ -DMULTI_THREAD=$(usex threads)
+ -DUSE_GITHASH=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local -a myctestargs=(
+ # Disable problematic "style_check" cpplint test,
+ # this also removes the python test dependency
+ --exclude-regex style_check
+ )
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS="You probably want to use lean with mathlib, you can either:
+ - Do not install mathlib globally and use local versions
+ - Use leanproject from sci-mathematics/mathlib-tools
+ $ leanproject global-install
+ - Use leanpkg and compile mathlib (which will take some time)
+ $ leanpkg install https://github.com/leanprover-community/mathlib"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}