summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-05-07 21:15:03 +1200
committerMichael Orlitzky <mjo@gentoo.org>2023-05-09 13:14:22 -0400
commit33ca4fe8799bed7fe7f32909a84363095dff0820 (patch)
tree96d938899b7d5e7212a14b84f992b19cc498e81d /sci-mathematics
parentwww-client/opera: remove old (diff)
downloadgentoo-33ca4fe8799bed7fe7f32909a84363095dff0820.tar.gz
gentoo-33ca4fe8799bed7fe7f32909a84363095dff0820.tar.bz2
gentoo-33ca4fe8799bed7fe7f32909a84363095dff0820.zip
sci-mathematics/eclib: add 20230424
New version by François in which I've bumped the soname/subslot. The latest version has a backwards-incompatible change, but the "age" component of the library version wasn't reset. The ebuild does that now. Closes: https://github.com/gentoo/gentoo/pull/30912 Signed-off-by: François Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20230424.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 47b26f363aac..9c0319db55ba 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1 +1,2 @@
DIST eclib-20221012.tar.bz2 922112 BLAKE2B 2a6e5dccdef7c3c3b8bb1a121706bbfbcaafa9fb50882e4e88f8fa826c3b1bcbec11dc55462cbd51da3ab263991ae357b151ff3bdbf453abfc30e82d2abdeac8 SHA512 9d04aefe9e35fbc1b18dd92b5ba872cf71f5ce1c94c9a0f1ff326c763bf144112d7d950ac80e2bd8d3780a303edeeac903754b4eb5fb241e87be7ef3f2738c19
+DIST eclib-20230424.tar.bz2 923074 BLAKE2B 00c314e54ff2ce37f3aa83b757c0f880aef563093ab33db5241dfeb1e78cfd21be4f6a5097965697d5b87aa1987da17bd47007a599717ebf39456717efa6ad2c SHA512 4c248c48fa563e53b9354f3822c4e95308320a809f2dcc3e116cba8a6f903b333e27b527da9a10dc8252052201c4fcf50d9747a75cf8438a98b9d3828eb3d9d9
diff --git a/sci-mathematics/eclib/eclib-20230424.ebuild b/sci-mathematics/eclib/eclib-20230424.ebuild
new file mode 100644
index 000000000000..b6530c437e9e
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20230424.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0/12"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # LT_CURRENT was bumped to 12 in this release but LT_AGE was left at
+ # two despite an interface being removed. Here we fix it so that the
+ # soname is correctly updated (and matches the expected subslot
+ # again).
+ sed -e 's/LT_AGE=2/LT_AGE=0/' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}