summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/espresso
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/espresso')
-rw-r--r--sci-physics/espresso/Manifest1
-rw-r--r--sci-physics/espresso/espresso-3.3.0.ebuild136
-rw-r--r--sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch23
-rw-r--r--sci-physics/espresso/metadata.xml14
4 files changed, 174 insertions, 0 deletions
diff --git a/sci-physics/espresso/Manifest b/sci-physics/espresso/Manifest
new file mode 100644
index 000000000000..638d0ca97c67
--- /dev/null
+++ b/sci-physics/espresso/Manifest
@@ -0,0 +1 @@
+DIST espresso-3.3.0.tar.gz 18952622 SHA256 64ea2684e4fc0d31c11969e49ec74c25138b4f74686f67b93c7e1103833ff08f SHA512 90edbbdc8d7f7247b5179fce0fad796a9488f82a1754519918c6588c932050675397d36e0167aae770db9803b6c22f7d14d23c04cf307d10802afd3d5d5edc20 WHIRLPOOL 3e9547f2da6676edf3de415fa848301f2959c3dfeef1c3f461b4e1eb202224ead7635748b47d42edb9f661dc5d672f38168e15ab6c55a9c9d7f102ae11f8574e
diff --git a/sci-physics/espresso/espresso-3.3.0.ebuild b/sci-physics/espresso/espresso-3.3.0.ebuild
new file mode 100644
index 000000000000..f35f8ce2d941
--- /dev/null
+++ b/sci-physics/espresso/espresso-3.3.0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-single-r1 savedconfig
+
+DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
+HOMEPAGE="http://espressomd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/espressomd.git"
+ EGIT_BRANCH="master"
+ AUTOTOOLS_AUTORECONF=1
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="mirror://nongnu/${PN}md/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="X cuda doc examples +fftw mpi packages python test -tk"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tk? ( X )"
+
+RESTRICT="tk? ( test )"
+
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ dev-lang/tcl:0=
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ fftw? ( sci-libs/fftw:3.0 )
+ mpi? ( virtual/mpi )
+ packages? ( dev-tcltk/tcllib )
+ tk? ( >=dev-lang/tk-8.4.18-r1:0= )
+ X? ( x11-libs/libX11 )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base )"
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+PATCHES=( "${FILESDIR}/${P}-cython-0.22.patch" )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with fftw) \
+ $(use_with cuda) \
+ $(use_with python python-interface) \
+ $(use_with mpi) \
+ $(use_with tk) \
+ $(use_with X x)
+ )
+ CXX=$(usex mpi "mpic++" "$(tc-getCXX)") autotools-utils_src_configure
+ restore_config myconfig.hpp
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+ [[ ${PV} = 9999 ]] && use doc && autotools-utils_src_compile ug dg tutorials
+}
+
+src_install() {
+ local i
+
+ autotools-utils_src_install
+
+ insinto /usr/share/${PN}
+ doins ${AUTOTOOLS_BUILD_DIR}/myconfig-sample.hpp
+
+ save_config ${AUTOTOOLS_BUILD_DIR}/src/core/myconfig-final.hpp
+
+ if use doc; then
+ if [[ ${PV} = 9999 ]] ; then
+ newdoc "${AUTOTOOLS_BUILD_DIR}"/doc/dg/dg.pdf developer_guide.pdf
+ newdoc "${AUTOTOOLS_BUILD_DIR}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${AUTOTOOLS_BUILD_DIR}"/doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ else
+ newdoc "${S}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${S}"/doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ fi
+ dohtml -r "${AUTOTOOLS_BUILD_DIR}"/doc/doxygen/html/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r samples/*
+ fi
+
+ if use packages; then
+ insinto /usr/share/${PN}/packages
+ doins -r packages/*
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Please read and cite:"
+ elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
+ elog "http://dx.doi.org/10.1016/j.cpc.2005.10.005"
+ echo
+ elog "If you need more features, change"
+ elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
+ elog "and reemerge with USE=savedconfig"
+ echo
+ elog "For a full feature list see:"
+ elog "/usr/share/${PN}/myconfig-sample.h"
+ echo
+}
diff --git a/sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch b/sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch
new file mode 100644
index 000000000000..22b726b480e1
--- /dev/null
+++ b/sci-physics/espresso/files/espresso-3.3.0-cython-0.22.patch
@@ -0,0 +1,23 @@
+From 9e6caa3294b0f5f377c16550a07429b73c871ac3 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <junghans@votca.org>
+Date: Thu, 12 Mar 2015 08:55:51 -0600
+Subject: [PATCH] fix build with cython-0.22
+
+---
+ src/python/espressomd/particle_data.pxd | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/espressomd/particle_data.pxd b/src/python/espressomd/particle_data.pxd
+index fff022b..4cc39e8 100644
+--- a/src/python/espressomd/particle_data.pxd
++++ b/src/python/espressomd/particle_data.pxd
+@@ -185,5 +185,5 @@ cdef class ParticleHandle(object):
+ cdef public int id
+ cdef bint valid
+ cdef Particle particleData
+- cdef int updateParticleData(self)
++ cdef int updateParticleData(self) except -1
+
+--
+2.0.5
+
diff --git a/sci-physics/espresso/metadata.xml b/sci-physics/espresso/metadata.xml
new file mode 100644
index 000000000000..1ef3470bdd04
--- /dev/null
+++ b/sci-physics/espresso/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name="cuda">Enable cuda support</flag>
+ <flag name="examples">Installs the examples</flag>
+ <flag name="packages">Installs extra subpackages</flag>
+ </use>
+</pkgmetadata>