summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-06-06 13:24:36 +0000
committerYixun Lan <dlan@gentoo.org>2024-06-06 13:33:00 +0000
commit3c87d888c7ae2287716824399b97e9307c273437 (patch)
tree0ea3a52fd9904b17b511fa01f7a5ee9c5c6cc958 /sys-apps/tuned
parentsys-apps/tuned: support python3.12 (diff)
downloadgentoo-3c87d888c7ae2287716824399b97e9307c273437.tar.gz
gentoo-3c87d888c7ae2287716824399b97e9307c273437.tar.bz2
gentoo-3c87d888c7ae2287716824399b97e9307c273437.zip
sys-apps/tuned: drop 2.22.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-apps/tuned')
-rw-r--r--sys-apps/tuned/Manifest1
-rw-r--r--sys-apps/tuned/tuned-2.22.0.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/sys-apps/tuned/Manifest b/sys-apps/tuned/Manifest
index 2dec83d7e17f..06f134d10ad1 100644
--- a/sys-apps/tuned/Manifest
+++ b/sys-apps/tuned/Manifest
@@ -1,2 +1 @@
-DIST tuned-2.22.0.tar.gz 254613 BLAKE2B 5354181ab300125d7011aa12c208bc9973c19bd34018ba83d772a9e2fa1598cb6582f952afb35d586bb24a2e3af077bdff22fa6e1e39fcdbe94bee090b2032a2 SHA512 653f946e8eff57eaa7e26b05c9215d60c8dcec6760b4a41a2855328e86b65f4dcbc0b2fd7d9f9355d00aae93f601c035a38d4e1611f30cb5003b417e31bea4dc
DIST tuned-2.22.1.tar.gz 254690 BLAKE2B 1942aed859425494df702a45900d6e0c26c799f19427cb1ff18160ed49cf8ac78ae3b73a39f1120a1dc5d344c3c1e61298085c54655aa13052600b946cb16a41 SHA512 160b1cab5477d84a0da89f584fe646b32162527a138d9b5957799c5f26598b98449733040710133a1c5bdd5588eee72549131ff163e777a105fc24e92edc6d8f
diff --git a/sys-apps/tuned/tuned-2.22.0.ebuild b/sys-apps/tuned/tuned-2.22.0.ebuild
deleted file mode 100644
index 574731427297..000000000000
--- a/sys-apps/tuned/tuned-2.22.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit optfeature python-single-r1 tmpfiles xdg-utils
-
-DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
-HOMEPAGE="https://github.com/redhat-performance/tuned"
-SRC_URI="https://github.com/redhat-performance/tuned/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-linux-procfs[${PYTHON_USEDEP}]
- dev-python/pyudev[${PYTHON_USEDEP}]
- ')"
-
-RDEPEND="
- ${DEPEND}
- app-emulation/virt-what
- dev-debug/systemtap
- sys-apps/dbus
- sys-apps/ethtool
- sys-power/powertop
- "
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i \
- -e "/^PYTHON/s:/usr/bin/python3:${EPREFIX}/usr/bin/${EPYTHON}:" \
- -e "/^export DOCDIR/s/$/&\-\$(VERSION)/g" \
- -e "/\$(DESTDIR)\/run\/tuned/d" \
- -e "/\$(DESTDIR)\/var\/lib\/tuned/d" \
- -e "/\$(DESTDIR)\/var\/log\/tuned/d" \
- Makefile || die
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- python_fix_shebang "${D}"
- python_optimize
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
- xdg_icon_cache_update
-
- optfeature_header
- optfeature "Optimize for power saving by spinning-down rotational disks" sys-apps/hdparm
- optfeature "Get hardware info" sys-apps/dmidecode
- optfeature "Optimize network txqueuelen" sys-apps/iproute2
-}