summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-02-04 23:19:36 -0500
committerMike Gilbert <floppym@gentoo.org>2017-02-04 23:19:36 -0500
commit1fb33c231cb6d5e1892bdc8fb8f5a201f420c24e (patch)
tree3de24ec4a14abf2b950f73bbdeeb2e1039f2badc /sys-boot
parentRevert "www-plugins/chrome-binary-plugins: drop libwidvinecdm.so" (diff)
downloadgentoo-1fb33c231cb6d5e1892bdc8fb8f5a201f420c24e.tar.gz
gentoo-1fb33c231cb6d5e1892bdc8fb8f5a201f420c24e.tar.bz2
gentoo-1fb33c231cb6d5e1892bdc8fb8f5a201f420c24e.zip
sys-boot/gnu-efi: filter -mfpmath=sse
Gentoo-Bug: https://bugs.gentoo.org/607992 Package-Manager: Portage-2.3.3_p47_p631453, Repoman-2.3.1_p40_p631453
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild8
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.4.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild
index 741b506373d1..96dae6470226 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit multilib toolchain-funcs
+inherit flag-o-matic multilib toolchain-funcs
DESCRIPTION="Library for build EFI Applications"
HOMEPAGE="http://gnu-efi.sourceforge.net/"
@@ -51,6 +51,10 @@ efimake() {
src_compile() {
tc-export BUILD_CC AR AS CC LD
+
+ # https://bugs.gentoo.org/607992
+ filter-mfpmath sse
+
if [[ ${CHOST} == x86_64* ]]; then
use abi_x86_32 && CHOST=i686 ABI=x86 efimake
use abi_x86_64 && efimake
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.4.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.4.ebuild
index 65873c623768..205eaf09a2f9 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0.4.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Library for build EFI Applications"
HOMEPAGE="http://gnu-efi.sourceforge.net/"
@@ -51,6 +51,10 @@ efimake() {
src_compile() {
tc-export BUILD_CC AR AS CC LD
+
+ # https://bugs.gentoo.org/607992
+ filter-mfpmath sse
+
if [[ ${CHOST} == x86_64* ]]; then
use abi_x86_32 && CHOST=i686 ABI=x86 efimake
use abi_x86_64 && efimake