summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 08:40:22 +0100
committerSam James <sam@gentoo.org>2022-10-28 08:41:25 +0100
commit393db9123abfef4ca346cf5758b579053e66e9e0 (patch)
tree3c5aed59c67ca74a9a0f8be4b0ff6c2cc39a8fe4 /sys-boot
parentdev-libs/zziplib: fix Python dep; workaround Clang 16 failure (diff)
downloadgentoo-393db9123abfef4ca346cf5758b579053e66e9e0.tar.gz
gentoo-393db9123abfef4ca346cf5758b579053e66e9e0.tar.bz2
gentoo-393db9123abfef4ca346cf5758b579053e66e9e0.zip
sys-boot/systemd-boot: drop 249.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/systemd-boot/Manifest1
-rw-r--r--sys-boot/systemd-boot/files/249-libshared-static.patch27
-rw-r--r--sys-boot/systemd-boot/files/249.9-cross-compile.patch23
-rw-r--r--sys-boot/systemd-boot/systemd-boot-249.9.ebuild131
4 files changed, 0 insertions, 182 deletions
diff --git a/sys-boot/systemd-boot/Manifest b/sys-boot/systemd-boot/Manifest
deleted file mode 100644
index af55a394e2a6..000000000000
--- a/sys-boot/systemd-boot/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST systemd-stable-249.9.tar.gz 10613893 BLAKE2B fc7a14fa3b0cc3d05fa9f20fde2efedd3ef0f011d9dce53b0a418994b4257cf753b228cf98f749fb2028d81db55ef30a6e3d9b138d86239cad4fc730d845f9e2 SHA512 ce57bc6c522082e55649fc1886c4dc818c89607e175df2c92feffe288dbd38757f36b30abeebe153f5be6b664a49d729405040a952473cb2133a2e39cf9cc164
diff --git a/sys-boot/systemd-boot/files/249-libshared-static.patch b/sys-boot/systemd-boot/files/249-libshared-static.patch
deleted file mode 100644
index c08e451af9fc..000000000000
--- a/sys-boot/systemd-boot/files/249-libshared-static.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From eac425295227c5deda4536fd647ecf11b643e1ca Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sun, 29 Aug 2021 09:22:33 -0400
-Subject: [PATCH] Link bootctl against libshared_static
-
----
- meson.build | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 738879eb21..96042b6906 100644
---- a/meson.build
-+++ b/meson.build
-@@ -2150,9 +2150,8 @@ if conf.get('ENABLE_EFI') == 1 and conf.get('HAVE_BLKID') == 1
- 'bootctl',
- 'src/boot/bootctl.c',
- include_directories : includes,
-- link_with : [libshared],
-+ link_with : [libshared_static, libsystemd_static],
- dependencies : [libblkid],
-- install_rpath : rootlibexecdir,
- install : true)
-
- public_programs += executable(
---
-2.33.0
-
diff --git a/sys-boot/systemd-boot/files/249.9-cross-compile.patch b/sys-boot/systemd-boot/files/249.9-cross-compile.patch
deleted file mode 100644
index e063d303c7d8..000000000000
--- a/sys-boot/systemd-boot/files/249.9-cross-compile.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 3d7fd38ea938ab194366f40ed7aa413ad33f2fad Mon Sep 17 00:00:00 2001
-From: Yu Watanabe <watanabe.yu+github@gmail.com>
-Date: Tue, 21 Dec 2021 20:10:09 +0900
-Subject: [PATCH] meson: fix cross compiling
-
-(cherry picked from commit 3112d756a36993900b70fbff98e69a2a43b970a8)
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 02495d16c9..c76cab535d 100644
---- a/meson.build
-+++ b/meson.build
-@@ -442,7 +442,7 @@ conf.set('SIZEOF_DEV_T', cc.sizeof('dev_t', prefix : '#include <sys/types.h>'))
- conf.set('SIZEOF_INO_T', cc.sizeof('ino_t', prefix : '#include <sys/types.h>'))
- conf.set('SIZEOF_TIME_T', cc.sizeof('time_t', prefix : '#include <sys/time.h>'))
- conf.set('SIZEOF_RLIM_T', cc.sizeof('rlim_t', prefix : '#include <sys/resource.h>'))
--conf.set('SIZEOF_TIMEX_MEMBER', cc.sizeof('((struct timex *)0)->freq', prefix : '#include <sys/timex.h>'))
-+conf.set('SIZEOF_TIMEX_MEMBER', cc.sizeof('typeof(((struct timex *)0)->freq)', prefix : '#include <sys/timex.h>'))
-
- decl_headers = '''
- #include <uchar.h>
diff --git a/sys-boot/systemd-boot/systemd-boot-249.9.ebuild b/sys-boot/systemd-boot/systemd-boot-249.9.ebuild
deleted file mode 100644
index 0a48d6771a9b..000000000000
--- a/sys-boot/systemd-boot/systemd-boot-249.9.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 2016-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit meson python-any-r1 toolchain-funcs
-
-DESCRIPTION="UEFI boot manager from systemd (formerly gummiboot)"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/"
-if [[ ${PV} == *.* ]]; then
- SRC_URI="https://github.com/systemd/systemd-stable/archive/v${PV}.tar.gz -> systemd-stable-${PV}.tar.gz"
- S="${WORKDIR}/systemd-stable-${PV}"
-else
- SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
- S="${WORKDIR}/systemd-${PV}"
-fi
-
-LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE=""
-RESTRICT="test"
-
-BDEPEND="
- app-text/docbook-xml-dtd:4.2
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt:0
- sys-devel/gettext
- dev-util/gperf
- virtual/pkgconfig
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/jinja[${PYTHON_USEDEP}]')
-"
-
-python_check_deps() {
- python_has_version "dev-python/jinja[${PYTHON_USEDEP}]"
-}
-
-COMMON_DEPEND="
- >=sys-apps/util-linux-2.30
-"
-DEPEND="${COMMON_DEPEND}
- >=sys-boot/gnu-efi-3.0.2
- sys-libs/libcap
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-apps/systemd
-"
-
-QA_FLAGS_IGNORED="usr/lib/systemd/boot/efi/.*"
-QA_EXECSTACK="usr/lib/systemd/boot/efi/*"
-
-PATCHES=(
- "${FILESDIR}/249-libshared-static.patch"
- "${FILESDIR}/249.9-cross-compile.patch"
-)
-
-src_configure() {
- # https://bugs.gentoo.org/725794
- tc-export OBJCOPY
-
- local emesonargs=(
- -Dblkid=true
- -Defi=true
- -Dgnu-efi=true
- -Defi-cc="$(tc-getCC)"
- -Defi-ld="$(tc-getLD)"
- -Defi-libdir="/usr/$(get_libdir)"
- -Dsplit-usr=true
- -Drootprefix="${EPREFIX:-/}"
-
- -Dacl=false
- -Dapparmor=false
- -Daudit=false
- -Dbzip2=false
- -Delfutils=false
- -Dgcrypt=false
- -Dgnutls=false
- -Dkmod=false
- -Dlibcryptsetup=false
- -Dlibcurl=false
- -Dlibidn=false
- -Dlibidn2=false
- -Dlibiptc=false
- -Dlz4=false
- -Dmicrohttpd=false
- -Dpam=false
- -Dqrencode=false
- -Dseccomp=false
- -Dselinux=false
- -Dxkbcommon=false
- -Dxz=false
- )
- meson_src_configure
-}
-
-set_efi_arch() {
- case "$(tc-arch)" in
- amd64) efi_arch=x64 ;;
- arm) efi_arch=arm ;;
- arm64) efi_arch=aa64 ;;
- x86) efi_arch=x86 ;;
- esac
-}
-
-src_compile() {
- local efi_arch
- set_efi_arch
- local targets=(
- bootctl
- man/bootctl.1
- man/kernel-install.8
- src/boot/efi/linux${efi_arch}.{efi,elf}.stub
- src/boot/efi/systemd-boot${efi_arch}.efi
- )
- meson_src_compile "${targets[@]}"
-}
-
-src_install() {
- local efi_arch
- set_efi_arch
- dobin "${BUILD_DIR}"/bootctl src/kernel-install/kernel-install
- doman "${BUILD_DIR}"/man/{bootctl.1,kernel-install.8}
- exeinto usr/lib/kernel/install.d
- doexe src/kernel-install/*.install
- insinto usr/lib/systemd/boot/efi
- doins "${BUILD_DIR}"/src/boot/efi/{linux${efi_arch}.{efi,elf}.stub,systemd-boot${efi_arch}.efi}
- einstalldocs
-}