summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-23 10:11:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-23 13:59:50 +0100
commitc1c8619c873830c4b54c687472f10cb7336bd48d (patch)
tree02c919e7472745f31f416f6bd2d410d5323b3f70 /sys-devel
parentsys-libs/libomp: Bump to 14.0.0 (diff)
downloadgentoo-c1c8619c873830c4b54c687472f10cb7336bd48d.tar.gz
gentoo-c1c8619c873830c4b54c687472f10cb7336bd48d.tar.bz2
gentoo-c1c8619c873830c4b54c687472f10cb7336bd48d.zip
sys-devel/clang-runtime: Bump to 14.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.0.ebuild
new file mode 100644
index 000000000000..18c271cc01bb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"