summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:34:45 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:50:18 +0200
commite48d079f0386c6630d107897e689ea6c4511479f (patch)
treebcefb9698551ba245818b568bef39ff8d83dc1b7 /sys-fs/jfsutils
parentsys-fs/jfsutils: don't call AR directly (diff)
downloadgentoo-e48d079f0386c6630d107897e689ea6c4511479f.tar.gz
gentoo-e48d079f0386c6630d107897e689ea6c4511479f.tar.bz2
gentoo-e48d079f0386c6630d107897e689ea6c4511479f.zip
sys-fs/jfsutils: fix building against gcc-10
Closes: https://bugs.gentoo.org/707314 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-fs/jfsutils')
-rw-r--r--sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch71
-rw-r--r--sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild1
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch b/sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch
new file mode 100644
index 000000000000..72160e8b4fae
--- /dev/null
+++ b/sys-fs/jfsutils/files/jfsutils-1.1.15-gcc10.patch
@@ -0,0 +1,71 @@
+Fix building with GCC 10
+
+Origin: https://sources.debian.org/patches/jfsutils/1.1.15-5/gcc10_fix-1.patch/
+
+--- jfsutils-1.1.15.old/fscklog/display.c
++++ jfsutils-1.1.15.new/fscklog/display.c
+@@ -54,7 +54,7 @@
+ * output: fsck extracted service log I/O buffer
+ *
+ */
+-char xchklog_buffer[XCHKLOG_BUFSIZE];
++static char xchklog_buffer[XCHKLOG_BUFSIZE];
+
+ /* + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
+ *
+--- jfsutils-1.1.15.old/libfs/logredo.c
++++ jfsutils-1.1.15.new/libfs/logredo.c
+@@ -87,9 +87,9 @@
+ * S T U F F F O R T H E L O G
+ *
+ */
+-struct logsuper logsup; /* log super block */
+-int32_t numdoblk; /* number of do blocks used */
+-int32_t numnodofile; /* number of nodo file blocks used */
++static struct logsuper logsup; /* log super block */
++static int32_t numdoblk; /* number of do blocks used */
++static int32_t numnodofile; /* number of nodo file blocks used */
+ int32_t numExtDtPg = 0; /* number of extended dtpage blocks used */
+
+ /*
+@@ -129,7 +129,7 @@
+ */
+
+ /* buffer header table */
+-struct bufhdr {
++static struct bufhdr {
+ int16_t next; /* 2: next on free/lru list */
+ int16_t prev; /* 2: previous on free/lru list */
+ int16_t hnext; /* 2: next on hash chain */
+@@ -142,7 +142,7 @@
+ } bufhdr[NBUFPOOL]; /* (24) */
+
+ /* buffer table */
+-struct bufpool {
++static struct bufpool {
+ char bytes[PSIZE];
+ } buffer[NBUFPOOL - 1];
+
+@@ -151,15 +151,16 @@
+ *
+ * log has its own 4 page buffer pool.
+ */
+-uint8_t afterdata[LOGPSIZE * 2]; /* buffer to read in redopage data */
++static uint8_t afterdata[LOGPSIZE * 2]; /* buffer to read in redopage data */
+
+ /*
+ * Miscellaneous
+ */
+-caddr_t prog; /* Program name */
+-int32_t mntcnt, bufsize;
+-char *mntinfo;
+-int32_t retcode; /* return code from logredo */
++static caddr_t prog; /* Program name */
++extern int32_t mntcnt;
++static int32_t bufsize;
++static char *mntinfo;
++static int32_t retcode; /* return code from logredo */
+ int end_of_transaction = 0;
+
+ /*
+
diff --git a/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
index d1f28184fb48..d828395c2a9c 100644
--- a/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
+++ b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
@@ -20,6 +20,7 @@ PATCHES=(
"${FILESDIR}"/${P}-linux-headers.patch #448844
"${FILESDIR}"/${P}-sysmacros.patch #580056
"${FILESDIR}"/${P}-check-for-ar.patch #726032
+ "${FILESDIR}"/${P}-gcc10.patch #707314
)
src_prepare() {