summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2023-07-09 12:46:58 +0200
committerSam James <sam@gentoo.org>2023-07-10 04:52:55 +0100
commit336bfe63da3050c4521bd656488a1842d802018f (patch)
treec32169dafe6a11c17252f27d52778574be56e1d0 /sys-fs
parentsys-fs/bees: drop 0.8 (diff)
downloadgentoo-336bfe63da3050c4521bd656488a1842d802018f.tar.gz
gentoo-336bfe63da3050c4521bd656488a1842d802018f.tar.bz2
gentoo-336bfe63da3050c4521bd656488a1842d802018f.zip
sys-fs/bees: add 0.9.3, drop 0.9
Signed-off-by: Kai Krakow <kai@kaishome.de> Closes: https://github.com/gentoo/gentoo/pull/31809 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bees/Manifest2
-rw-r--r--sys-fs/bees/bees-0.9.3.ebuild (renamed from sys-fs/bees/bees-0.9.ebuild)22
2 files changed, 15 insertions, 9 deletions
diff --git a/sys-fs/bees/Manifest b/sys-fs/bees/Manifest
index d7c0ed7ac2bc..f00537cdc1c0 100644
--- a/sys-fs/bees/Manifest
+++ b/sys-fs/bees/Manifest
@@ -1,2 +1,2 @@
DIST bees-0.10.tar.gz 177509 BLAKE2B 269cf65d5250a07297dfaee6c0fd6bc25199d63fe423d63ce39df8bcdb64d6f8110a0e03d0dc7dc1b105a8886f2a9364da8878481546eaa8dbf3dc46abc569ed SHA512 77a4ae3d66430c2d9dc0351c16c60bad95f21e238fc00f5f5787f55929ba75ee25212ac4bb4a3e4a9419cec27bbcfd2987aa925a54bc2872609b38a698dbedc3
-DIST bees-0.9.tar.gz 176570 BLAKE2B f210afc342debb9fcdaba977ecccee9c07929197ccda942566634ef4d08c8bd11edb67ea50e05b046771faad212a9c3e01fc98c74dc759785afa588ba1d68b06 SHA512 dce90fc6f1741356331cc8c43536ea497c41a702be1b2bc2196f9ad0d5083d7255f15d529cf2804e4f36675ccc4a1d11d25ee266071a984199706ae2cd285c43
+DIST bees-0.9.3.tar.gz 177265 BLAKE2B f0363771647ee07b12afe3ef44c1453e4677e12b051e33a81517a6044a459237b72712a09b31895147cd171a649ba15fc75676f34df46c9520248eae09e193e1 SHA512 5517773478cd56915ec3aee6542f6128a0f72b10aa96708d20778a76a427890bdfd9d8ba775b9dff3395d2e203fa2995070f9aca509b8150b9a9bcf076828ebb
diff --git a/sys-fs/bees/bees-0.9.ebuild b/sys-fs/bees/bees-0.9.3.ebuild
index 4834204acfcf..1b164eb56b08 100644
--- a/sys-fs/bees/bees-0.9.ebuild
+++ b/sys-fs/bees/bees-0.9.3.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/Zygo/bees.git"
else
SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64"
+ KEYWORDS="~amd64 ~arm64"
fi
LICENSE="GPL-3"
@@ -29,6 +29,10 @@ RDEPEND="${DEPEND}"
CONFIG_CHECK="~BTRFS_FS"
ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
+PATCHES=(
+ "${FILESDIR}/0001-HACK-crucible-Work-around-kernel-memory-fragmentatio.patch"
+)
+
pkg_pretend() {
if [[ ${MERGE_TYPE} != buildonly ]]; then
if kernel_is -lt 4 11; then
@@ -66,13 +70,15 @@ pkg_pretend() {
ewarn "https://github.com/Zygo/bees/blob/master/docs/btrfs-kernel.md"
ewarn
fi
- if kernel_is -ge 5 4 0; then
- ewarn "With kernel version 5.4 or later, the kernel may hang when multiple threads"
- ewarn "are running LOGICAL_INO and dedupe ioctl. This is not exclusively triggered"
- ewarn "by bees but also other software running such operations, bees will just more"
- ewarn "likely trigger this bug. You can work around this issue by reducing the"
- ewarn "thread count of bees to 1."
- ewarn
+ if kernel_is -gt 5 15 106; then
+ if kernel_is -lt 6 3 10; then
+ ewarn "With kernel versions 5.15.107 or later, there is a memory fragmentation"
+ ewarn "issue with LOGICAL_INO which can lead to cache thrashing and cause IO"
+ ewarn "latency spikes. This version ships with a work-around at the cost of not"
+ ewarn "handling highly duplicated filesystems that well. More details:"
+ ewarn "https://github.com/Zygo/bees/issues/260"
+ ewarn
+ fi
fi
elog "Bees recommends running the latest current kernel for performance and"