summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-18 23:27:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-18 23:28:31 +0300
commit19d180f86cff44e8a3ca06b903a954d0278fa6c8 (patch)
tree2d7a0168a9269d0e2ca76f2461e0cff8d4a94e99 /sys-process/iotop-c
parentdev-scheme/mit-scheme: add missing postgresql cond dep (diff)
downloadgentoo-19d180f86cff44e8a3ca06b903a954d0278fa6c8.tar.gz
gentoo-19d180f86cff44e8a3ca06b903a954d0278fa6c8.tar.bz2
gentoo-19d180f86cff44e8a3ca06b903a954d0278fa6c8.zip
sys-process/iotop-c: add 1.22
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process/iotop-c')
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.22.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index 17a93e204986..04c5ba77e04f 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1,3 +1,4 @@
DIST iotop-c-1.19.tar.gz 115025 BLAKE2B 0b45a73afc5dd160692fa1a3d028afff2b4b242a008470679a669182baa56b133f5fd26f9cb3ed20ebfe18b7fdeba9ca98a7801299c8c9b8d776a58fed2725d2 SHA512 489ddd67eb4e9159058c94f614534290b302abd5af8b424f6c42df20f21362c60dc30e7fd0bac883b8bf032e72843b4b82dbfb77b670258728ef0fa9dbb7dfa3
DIST iotop-c-1.20.tar.gz 124352 BLAKE2B ec14a70e7952b6a5d4a74dbac3cd3c5f18e4b4c447d7b8c8515f8e59f4d859ed8110da44329f5cf2ed36cac764c509d080cb7b75b0caa50896fa77abe84880ca SHA512 1e4b5a9f166ff021b53e13a1c975328b6f966e468c3bf834a0504e41b7c3f3f9052516d6b57082692871a69b5675a86d16fb7f487e2aa44dbb5e81a8a0d806bb
DIST iotop-c-1.21.tar.gz 127634 BLAKE2B 9dd84bd3a1c7fe44b8e393114428b3d7f1c8f313ad6fcc13e94ff2ed3d139ce45f2bc6c365218de865f67550fe9ed2bf320566f13b7b0190f2cc1a57026a52f1 SHA512 2cc01767f234b46ed2d02e96dc97e684cf6174c63038026362a4f6e08b30a4321cb9597727b64710162c5dc35fbb94306fc719d69fa5320f691849f91f8b62bf
+DIST iotop-c-1.22.tar.gz 135078 BLAKE2B 90a441402b19ab5af9d5155f5d335e992e8acd702cbc2ebfb4b99dbc0be672fe07d462aab2c00a14702f584c0762b3b0ae4336022007bc956309ab781cbd2aa8 SHA512 863f4e602e13c91302ef3e2de7bf917418cb389a427fd0a6579c31a991d628112d0b479a2287944c4b3f3b5c4b13815ec57d30687fc48de7b782586e56ee62d8
diff --git a/sys-process/iotop-c/iotop-c-1.22.ebuild b/sys-process/iotop-c/iotop-c-1.22.ebuild
new file mode 100644
index 000000000000..d3fb15e7e2eb
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}