summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-14 10:46:49 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-17 10:37:00 +0100
commitfe015b2c6b786bb404087248673686d3666c1e7e (patch)
tree467ec3e738112a58802dd82d6cec6b19911561e0 /sys-process
parentsys-apps/ripgrep: Use new cargo_target_dir helper (diff)
downloadgentoo-fe015b2c6b786bb404087248673686d3666c1e7e.tar.gz
gentoo-fe015b2c6b786bb404087248673686d3666c1e7e.tar.bz2
gentoo-fe015b2c6b786bb404087248673686d3666c1e7e.zip
sys-process/procs: Use new cargo_target_dir helper
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procs/procs-0.14.4.ebuild8
-rw-r--r--sys-process/procs/procs-0.14.5.ebuild6
2 files changed, 7 insertions, 7 deletions
diff --git a/sys-process/procs/procs-0.14.4.ebuild b/sys-process/procs/procs-0.14.4.ebuild
index ed9880991d01..fd08a1055ff8 100644
--- a/sys-process/procs/procs-0.14.4.ebuild
+++ b/sys-process/procs/procs-0.14.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Autogenerated by pycargoebuild 0.6.3
@@ -280,14 +280,14 @@ QA_FLAGS_IGNORED="usr/bin/procs"
src_install() {
cargo_src_install
- target/$(usex debug debug release)/procs --gen-completion bash || die
+ "$(cargo_target_dir)"/procs --gen-completion bash || die
newbashcomp procs.bash procs
- target/$(usex debug debug release)/procs --gen-completion zsh || die
+ "$(cargo_target_dir)"/procs --gen-completion zsh || die
insinto /usr/share/zsh/site-functions
doins _procs
- target/$(usex debug debug release)/procs --gen-completion fish || die
+ "$(cargo_target_dir)"/procs --gen-completion fish || die
insinto /usr/share/fish/vendor_completions.d
doins procs.fish
}
diff --git a/sys-process/procs/procs-0.14.5.ebuild b/sys-process/procs/procs-0.14.5.ebuild
index a306320fc092..5447e7e7fc4c 100644
--- a/sys-process/procs/procs-0.14.5.ebuild
+++ b/sys-process/procs/procs-0.14.5.ebuild
@@ -308,14 +308,14 @@ QA_FLAGS_IGNORED="usr/bin/procs"
src_install() {
cargo_src_install
- target/$(usex debug debug release)/procs --gen-completion bash || die
+ "$(cargo_target_dir)"/procs --gen-completion bash || die
newbashcomp procs.bash procs
- target/$(usex debug debug release)/procs --gen-completion zsh || die
+ "$(cargo_target_dir)"/procs --gen-completion zsh || die
insinto /usr/share/zsh/site-functions
doins _procs
- target/$(usex debug debug release)/procs --gen-completion fish || die
+ "$(cargo_target_dir)"/procs --gen-completion fish || die
insinto /usr/share/fish/vendor_completions.d
doins procs.fish
}