summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2019-12-28 09:23:40 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2019-12-28 09:23:40 +0100
commitcc01c70cace6af11209ee41efbb97230d26939c8 (patch)
treed12281da8b60115d0770e4067eee4bf98f87c759 /x11-libs
parentnet-vpn/wireguard-tools: make wg-quick(8) optional (diff)
downloadgentoo-cc01c70cace6af11209ee41efbb97230d26939c8.tar.gz
gentoo-cc01c70cace6af11209ee41efbb97230d26939c8.tar.bz2
gentoo-cc01c70cace6af11209ee41efbb97230d26939c8.zip
x11-libs/fox: address QA nits
This wasn't my ebuild originally. Indeed it was quite hairy. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fox/fox-1.7.67.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/x11-libs/fox/fox-1.7.67.ebuild b/x11-libs/fox/fox-1.7.67.ebuild
index 0f09d1a6053e..564900ecba7d 100644
--- a/x11-libs/fox/fox-1.7.67.ebuild
+++ b/x11-libs/fox/fox-1.7.67.ebuild
@@ -5,6 +5,10 @@ EAPI=7
inherit autotools
+DESCRIPTION="C++ Toolkit for developing Graphical User Interfaces easily and effectively"
+HOMEPAGE="http://www.fox-toolkit.org/"
+SRC_URI="ftp://ftp.fox-toolkit.org/pub/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="1.7"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -14,22 +18,18 @@ RDEPEND="x11-libs/libXrandr
x11-libs/libXcursor
x11-libs/fox-wrapper
bzip2? ( app-arch/bzip2 )
- jpeg? ( virtual/jpeg:= )
+ jpeg? ( virtual/jpeg )
opengl? ( virtual/glu virtual/opengl )
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0= )
truetype? ( media-libs/freetype:2
x11-libs/libXft )
zlib? ( sys-libs/zlib )
- doc? ( app-doc/doxygen )
"
DEPEND="${RDEPEND}
x11-base/xorg-proto
x11-libs/libXt"
-
-DESCRIPTION="C++ Toolkit for developing Graphical User Interfaces easily and effectively"
-HOMEPAGE="http://www.fox-toolkit.org/"
-SRC_URI="ftp://ftp.fox-toolkit.org/pub/${P}.tar.gz"
+BDEPEND="doc? ( app-doc/doxygen )"
PATCHES=( "${FILESDIR}"/"${PN}"-1.7.67-no-truetype.patch )
@@ -53,7 +53,7 @@ src_prepare() {
src_configure() {
econf \
- $(use debug && echo --enable-debug || echo --enable-release) \
+ --enable-$(usex debug debug release) \
$(use_enable bzip2 bz2lib) \
$(use_enable jpeg) \
$(use_with opengl) \
@@ -65,16 +65,16 @@ src_configure() {
}
src_compile() {
- emake || die "compile error"
+ emake
use doc && emake -C "${S}"/doc docs
}
src_install() {
emake install \
DESTDIR="${D}" \
- htmldir=/usr/share/doc/${PF}/html \
- artdir=/usr/share/doc/${PF}/html/art \
- screenshotsdir=/usr/share/doc/${PF}/html/screenshots
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ artdir="${EPREFIX}"/usr/share/doc/${PF}/html/art \
+ screenshotsdir="${EPREFIX}"/usr/share/doc/${PF}/html/screenshots
CP="${ED}/usr/bin/ControlPanel"
if [[ -f ${CP} ]] ; then
@@ -83,7 +83,7 @@ src_install() {
fi
for doc in ADDITIONS AUTHORS LICENSE_ADDENDUM README TRACING ; do
- [ -f $doc ] && dodoc $doc
+ [[ -f $doc ]] && dodoc $doc
done
# remove documentation if USE=-doc
@@ -91,7 +91,8 @@ src_install() {
# install class reference docs if USE=doc
if use doc && [[ -z ${FOX_COMPONENT} ]] ; then
- dohtml -r "${S}/doc/ref"
+ docinto html
+ dodoc -r "${S}/doc/ref"
fi
# slot fox-config