summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 20:04:48 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 21:45:43 -0500
commitef30c38205d4efb7cd1713bc56e4f8a4f0604272 (patch)
tree247ca16ef350c37bcb90cf53c5dd8be1f61f3099 /x11-misc/mate-notification-daemon
parentx11-themes/mate-themes: Import 1.10.x from Project:MATE repo (diff)
downloadgentoo-ef30c38205d4efb7cd1713bc56e4f8a4f0604272.tar.gz
gentoo-ef30c38205d4efb7cd1713bc56e4f8a4f0604272.tar.bz2
gentoo-ef30c38205d4efb7cd1713bc56e4f8a4f0604272.zip
x11-misc/mate-notification-daemon: Import 1.10.x from Project:MATE repo
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-misc/mate-notification-daemon')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest1
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.10.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index 7cd357b12949..acbc67c71281 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1,2 +1,3 @@
+DIST mate-notification-daemon-1.10.2.tar.xz 304100 SHA256 f421deaf684368cc426954bbd6ecd1aa518fa50f44c03e0f68a50ae8aa9b35b3 SHA512 6b7cc9c7450da340c2a6061307c46a0fdabb4ff28fd6dfa12180f4007fcd33ea936d767abae19c571e6f63fa8a261df40dfc2bfb38d8efebbe9becc4ba16dbcc WHIRLPOOL fba269bdf8a0ad37889b9ebaf4d2da95835187714ce958989ca76471a82afdd1ed4970fe520936d59b8a961988b05f557cce32235e4a37eae355b980045b1b1b
DIST mate-notification-daemon-1.8.0.tar.xz 301228 SHA256 21f29513efdbc97ab87e7813bb81c2d23038f5c49a57f55107316f99ae79cfb0 SHA512 a37fe85998b18148eb1dcf4f96a6a18a8f2b9acdbeaf356decc41b220e8db58db914cd1f2ff665081061e63119773445d9fb874c19ab8fd5396fc7b927f6267d WHIRLPOOL fc7a093b558745bcceee708fdf6ad24df41ebbc2beebc41b742b59e7ef1b2c9b59a9daea4166c7713264e5a2c804e63e5f9bf17aadaba718c1e94a3977a55744
DIST mate-notification-daemon-1.8.1.tar.xz 300984 SHA256 322b0f461d0972536916191481ee8f71b94c9534049498617c78218c9ce792a6 SHA512 45d9d8e95628a4ea384335a2293c85cda3177676acf6b4d3ee877f85f7b631c8f19429884017414f6882c4b6dcb32a1c2dbeb3bebaee8f8ab3107003bf3c9d92 WHIRLPOOL 4c88feacefd6e1f5b741e19694f8c17e83ff0963340b4f6a90bec07d532608e39ad617f41d5301e703dc3c3326021062edd748a44899e61905cabd1173b86120
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.10.2.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.10.2.ebuild
new file mode 100644
index 000000000000..2662425b3706
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.10.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE Notification daemon"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.78:0
+ >=dev-libs/glib-2.36:2
+ >=media-libs/libcanberra-0.4:0[gtk]
+ >=sys-apps/dbus-1:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-2.24:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ >=x11-libs/libwnck-1:1
+ virtual/libintl:0
+ !x11-misc/notify-osd:*
+ !x11-misc/qtnotifydaemon:*
+ !x11-misc/notification-daemon:*"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ gnome2_src_install
+
+ cat <<-EOF > "${T}/org.freedesktop.Notifications.service"
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/mate-notification-daemon
+ EOF
+
+ insinto /usr/share/dbus-1/services
+ doins "${T}/org.freedesktop.Notifications.service"
+}