summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/revelation
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/revelation')
-rw-r--r--x11-misc/revelation/Manifest1
-rw-r--r--x11-misc/revelation/metadata.xml8
-rw-r--r--x11-misc/revelation/revelation-0.4.14-r1.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/revelation/Manifest b/x11-misc/revelation/Manifest
new file mode 100644
index 000000000000..bc8c4148a363
--- /dev/null
+++ b/x11-misc/revelation/Manifest
@@ -0,0 +1 @@
+DIST revelation-0.4.14.tar.xz 316096 SHA256 38a532e7c528076f82ef3564b5a75d0a37387492007cf49f2e4ef2c3eee9454d SHA512 0af5b7eea47a7706dd164f4f0a1da12fd2595e8add1455e4e4092e4b6aa1507faf2c94227dd838734bdc19fef9d268938362fca2d3cde59897580598eefa1145 WHIRLPOOL 5e65fa3e4e2ee1c13b5095ed00426987d74898113135e5ede878b206d01877bfa732eb145234a4a8889ca633a7b830a6d3621386dc8fa3579defdfbc66c3aeb8
diff --git a/x11-misc/revelation/metadata.xml b/x11-misc/revelation/metadata.xml
new file mode 100644
index 000000000000..cc160542fb5e
--- /dev/null
+++ b/x11-misc/revelation/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tristan@gentoo.org</email>
+ <name>Tristan Heaven</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/revelation/revelation-0.4.14-r1.ebuild b/x11-misc/revelation/revelation-0.4.14-r1.ebuild
new file mode 100644
index 000000000000..2bbfc3773bed
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.4.14-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+GCONF_DEBUG="no"
+
+inherit python-single-r1 gnome2
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="http://revelation.olasagasti.info/"
+SRC_URI="https://www.bitbucket.org/erikg/revelation/downloads/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/libgnome-python[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-libs/cracklib[python,${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ gnome2_src_configure \
+ --without-applet \
+ --disable-desktop-update \
+ --disable-mime-update
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${ED}"
+}