summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 08:05:08 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:32 +0100
commit2327b43b8a32f739e3c5e906633a0e986799d9d5 (patch)
tree1a096d689521afe76de396e35b088df4f099a049 /x11-plugins/gkwebmon
parentx11-plugins/gkrellweather: tidy up patch (diff)
downloadgentoo-2327b43b8a32f739e3c5e906633a0e986799d9d5.tar.gz
gentoo-2327b43b8a32f739e3c5e906633a0e986799d9d5.tar.bz2
gentoo-2327b43b8a32f739e3c5e906633a0e986799d9d5.zip
x11-plugins/gkwebmon: respect PKG_CONFIG, depend on pkgconfig
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkwebmon')
-rw-r--r--x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch4
-rw-r--r--x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild9
2 files changed, 9 insertions, 4 deletions
diff --git a/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch b/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch
index 7b3ee50f5321..5ffe8f12ed42 100644
--- a/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch
+++ b/x11-plugins/gkwebmon/files/gkwebmon-0.2-cc-cflags-ldflags.patch
@@ -18,8 +18,8 @@ index b422e79..d89977f 100644
-GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
-GTK_LIB = `pkg-config gtk+-2.0 --libs`
-+GTK_INCLUDE = $(shell pkg-config gtk+-2.0 --cflags)
-+GTK_LIB = $(shell pkg-config gtk+-2.0 --libs)
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
-#FLAGS = -O2 -Wall -fPIC -std=c99 -pedantic $(GTK_INCLUDE)
diff --git a/x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild b/x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild
index 5a5387b6c02c..469e62b16153 100644
--- a/x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild
+++ b/x11-plugins/gkwebmon/gkwebmon-0.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,7 +17,10 @@ KEYWORDS="~alpha ~amd64 ppc ~sparc x86"
RDEPEND="
app-admin/gkrellm:2[X]
dev-libs/openssl:0="
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}"/${P}-cc-cflags-ldflags.patch
@@ -25,5 +28,7 @@ PATCHES=(
)
src_compile() {
+ tc-export PKG_CONFIG
+
emake CC="$(tc-getCC)"
}