summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmrack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmrack')
-rw-r--r--x11-plugins/wmrack/Manifest2
-rw-r--r--x11-plugins/wmrack/metadata.xml8
-rw-r--r--x11-plugins/wmrack/wmrack-1.3.ebuild40
-rw-r--r--x11-plugins/wmrack/wmrack-1.4.ebuild34
4 files changed, 84 insertions, 0 deletions
diff --git a/x11-plugins/wmrack/Manifest b/x11-plugins/wmrack/Manifest
new file mode 100644
index 000000000000..822ccbf5ec30
--- /dev/null
+++ b/x11-plugins/wmrack/Manifest
@@ -0,0 +1,2 @@
+DIST wmrack-1.3.tar.gz 61120 SHA256 0aa26cba5feeeabe6a03524557f617f3a30e36b230997a1e5ae5be0ea92ab1d4
+DIST wmrack-1.4.tar.gz 124243 SHA256 198855b1672cf78c2fa6d486e5490c9fb0d09f850e4e7ad80b478aad36bfb219 SHA512 27ed399a56f7f37e494005f02e74a09ad22c448ac288a3d2123987488ce65460f4c80841e8ff0fe3ff20db156130bc9e4894b42280181a1af58e06c1f8320a1e WHIRLPOOL 2ced5caf20cb47bb7420ccd3fd144cb4145d2303dbb6bde58d42996003528db5db649aec5d7ae35c9f9a17445df3801006479377cf9bbded623f1b22b500af1f
diff --git a/x11-plugins/wmrack/metadata.xml b/x11-plugins/wmrack/metadata.xml
new file mode 100644
index 000000000000..8c4a9359094d
--- /dev/null
+++ b/x11-plugins/wmrack/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">wmrack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmrack/wmrack-1.3.ebuild b/x11-plugins/wmrack/wmrack-1.3.ebuild
new file mode 100644
index 000000000000..f660eca22c15
--- /dev/null
+++ b/x11-plugins/wmrack/wmrack-1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="a sound mixer and CD player dockapp"
+HOMEPAGE="http://wmrack.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:gcc:$(CC):' "${S}"/Makefile.in
+ sed -i -e 's:$(OBJECTS) -o:$(OBJECTS) $(LDFLAGS) -o:' "${S}"/Makefile.in
+}
+
+src_compile() {
+ tc-export CC
+ econf --x-includes=/usr/include --x-libraries=/usr/$(get_libdir)
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake -j1 LIBDIR="${D}/usr/$(get_libdir)/WMRack" \
+ MANDIR="${D}/usr/share/man" BINDIR="${D}/usr/bin" \
+ install || die "emake install failed."
+
+ dodoc CHANGES README TODO
+}
diff --git a/x11-plugins/wmrack/wmrack-1.4.ebuild b/x11-plugins/wmrack/wmrack-1.4.ebuild
new file mode 100644
index 000000000000..955ecfb8459a
--- /dev/null
+++ b/x11-plugins/wmrack/wmrack-1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+DESCRIPTION="a sound mixer and CD player dockapp"
+HOMEPAGE="http://wmrack.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_prepare() {
+ sed -i -e 's:gcc:$(CC):' "${S}"/Makefile.in
+ sed -i -e 's:$(OBJECTS) -o:$(OBJECTS) $(LDFLAGS) -o:' "${S}"/Makefile.in
+}
+
+src_install() {
+ emake LIBDIR="${D}/usr/$(get_libdir)/WMRack" \
+ MANDIR="${D}/usr/share/man" BINDIR="${D}/usr/bin" \
+ install
+
+ dodoc CHANGES README TODO
+}