summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2022-12-04 23:27:19 -0500
committerSam James <sam@gentoo.org>2022-12-24 07:03:59 +0000
commit7575d5d04dd87ab5b8007e24372cac44e92380ce (patch)
treef78686d19df191b733b7de6e4c95e13c69faedd6 /x11-wm/muffin
parentgnome-extra/nemo-fileroller: drop 5.6.0 (diff)
downloadgentoo-7575d5d04dd87ab5b8007e24372cac44e92380ce.tar.gz
gentoo-7575d5d04dd87ab5b8007e24372cac44e92380ce.tar.bz2
gentoo-7575d5d04dd87ab5b8007e24372cac44e92380ce.zip
x11-wm/muffin: add 5.6.2
Drop deprecated dependencies. Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm/muffin')
-rw-r--r--x11-wm/muffin/Manifest1
-rw-r--r--x11-wm/muffin/muffin-5.6.2.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/x11-wm/muffin/Manifest b/x11-wm/muffin/Manifest
index 69776f3fc8d8..7c6f40696c25 100644
--- a/x11-wm/muffin/Manifest
+++ b/x11-wm/muffin/Manifest
@@ -1,2 +1,3 @@
DIST muffin-5.2.1.tar.gz 5197177 BLAKE2B 9703a2e2c5ef75c7d4da3e201b60033a7ba549d94106df33aa9b89d0029f52c06fb4be00dd4c4d996bb083a790635a8227c8ff729dc43940f70b679e1b46924d SHA512 fa88a88f77a1cb84c2159fac8ab3ed38ae1054d3a01bb100aa264e8b91493a744da6e83ffad9190f0f7a07bd26022fea12d13a60e213d57f289685fba1810eb6
DIST muffin-5.6.0.tar.gz 4516015 BLAKE2B 19136768b7060186db9228bcfc01b4f5f94a3e66222cf21ad07d67ada415fd7bcf40fa13b0f4f292a2468671ce9ff15e24fa39553009109a557ffc1bbb8080b3 SHA512 9d36ac4f9e9ee91c2712c51b7a7ec0223ddb3178739b6b2e644d54e425420ceb99bd72e5da129d2f8a42c5693eba144a4b0713bc550f09339a3d15136d0953dd
+DIST muffin-5.6.2.tar.gz 4517162 BLAKE2B 95d4599f59838e1b281683ddcfb06eb152274482991ae2eea4e5c47056072df5714fc187967bdd58342ce660e3874c606de29f0e9f089d5b8511f116e703aca4 SHA512 14f71e15cedc7956f50a6b84d78ffcd1d20dba194206dd0df68147bcf60d2143eccaa1b23bf70675f4017cadd03698b6f79abedb754a04be20d73bbdbe724458
diff --git a/x11-wm/muffin/muffin-5.6.2.ebuild b/x11-wm/muffin/muffin-5.6.2.ebuild
new file mode 100644
index 000000000000..c73c457aa4de
--- /dev/null
+++ b/x11-wm/muffin/muffin-5.6.2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils meson xdg-utils virtualx
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/muffin"
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+ LGPL-2+ LGPL-2.1+ MIT SGI-B-2.0"
+SLOT="0"
+IUSE="input_devices_wacom +introspection screencast sysprof test udev"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+# Dependencies listed in meson order
+COMDEPEND="
+ x11-libs/libX11
+ >=media-libs/graphene-1.9.3[introspection?]
+ >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/pango-1.20.0[introspection?]
+ >=x11-libs/cairo-1.10.0:=[X]
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.61.1:2
+ >=dev-libs/json-glib-0.12.0[introspection?]
+ >=gnome-extra/cinnamon-desktop-5.6:0=
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXi-1.7.4
+ x11-libs/libXtst
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=x11-libs/libxkbcommon-0.4.3[X]
+ x11-libs/libXrender
+ >=x11-libs/libXrandr-1.5.0
+ x11-libs/libxcb:=
+ x11-libs/libXinerama
+ x11-libs/libXau
+ x11-libs/libICE
+ >=app-accessibility/at-spi2-core-2.46.0:2[introspection?]
+ >=media-libs/libcanberra-0.26
+ sys-apps/dbus
+ media-libs/libglvnd[X]
+ media-libs/mesa[X(+),egl(+)]
+ x11-libs/libSM
+ >=x11-libs/startup-notification-0.7:=
+
+ input_devices_wacom? ( >=dev-libs/libwacom-0.13:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.41.3:= )
+ screencast? ( >=media-video/pipewire-0.3.0:= )
+ sysprof? ( >=dev-util/sysprof-capture-3.35.2:3 )
+ udev? ( >=virtual/libudev-228:=
+ >=dev-libs/libgudev-232 )
+"
+RDEPEND="${COMDEPEND}
+ gnome-extra/zenity
+"
+DEPEND="${COMDEPEND}
+ x11-base/xorg-proto
+
+ sysprof? ( dev-util/sysprof-common )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# Wayland is not supported upstream.
+src_configure() {
+ local emesonargs=(
+ -Dopengl=true
+ #opengl_libname
+ #gles2_libname
+ -Dgles2=false # wayland
+ -Degl=true
+ -Dglx=true
+ $(meson_use screencast remote_desktop)
+ $(meson_use udev)
+ $(meson_use input_devices_wacom libwacom)
+ -Dpango_ft2=true
+ -Dstartup_notification=true
+ -Dsm=true
+ $(meson_use introspection)
+ $(meson_use test cogl_tests)
+ $(meson_use test clutter_tests)
+ -Dcore_tests=false # wayland
+ $(meson_use test tests)
+ $(meson_use sysprof profiler)
+ -Dinstalled_tests=false
+ #verbose
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ glib-compile-schemas "${BUILD_DIR}"/data
+ GSETTINGS_SCHEMA_DIR="${BUILD_DIR}"/data virtx meson_src_test --no-suite flaky
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}