summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-26 00:36:03 +0100
committerSam James <sam@gentoo.org>2021-07-26 00:36:03 +0100
commit482c39963295ed5f10d36f56685eb360b607aaca (patch)
treec16ff86da42d920ba7a4ea61301b08b71b238c12 /x11-wm
parentx11-misc/slim: restore dropped HOMEPAGE (diff)
downloadgentoo-482c39963295ed5f10d36f56685eb360b607aaca.tar.gz
gentoo-482c39963295ed5f10d36f56685eb360b607aaca.tar.bz2
gentoo-482c39963295ed5f10d36f56685eb360b607aaca.zip
x11-wm/pekwm: add 0.1.18
Closes: https://bugs.gentoo.org/724868 Closes: https://bugs.gentoo.org/786675 Closes: https://bugs.gentoo.org/767763 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/pekwm/Manifest1
-rw-r--r--x11-wm/pekwm/pekwm-0.1.18.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-wm/pekwm/Manifest b/x11-wm/pekwm/Manifest
index 7ced27df08e8..3e6d8f6527fd 100644
--- a/x11-wm/pekwm/Manifest
+++ b/x11-wm/pekwm/Manifest
@@ -1,2 +1,3 @@
DIST pekwm-0.1.17.tar.gz 429100 BLAKE2B 2b467539ef47f4404411f25146f9f945f9a63b7e4c85c997ed2cd0bf76ea713758e3a09dc9648064c02ab29818399623d12d78394f250c79f8f667a6e057281c SHA512 1950888402f11c5cd72c9d82de976c472d4a0443da206629a039d19a1729660fd7cd09535d35984d554dcdb366918d9e29536b1272521f36f7e54499df0c14af
+DIST pekwm-0.1.18.tar.gz 441810 BLAKE2B 8c3e98490681eed68e0f127c38c1653f8d643ceca2ddf8388f6b434d16daeb376fc9337de71786a658e9d9e7a080de922207173edb624b78732bc14da5d42eeb SHA512 31fe291b245b6e13fdfe27878162fd405fd60a766e9a7e762e817391179e7f82c41b664fba568af91e009582729e4633d23f76db95302f6f702cb74c2571db15
DIST pekwm-themes.tar.bz2 138599 BLAKE2B b0c103d7ade6f9bb1ed19b7e12cfcf00fb48be7e1ed141a4b52aee404ebf9c7af5d29af166ff7265a720ca8d122ad7eddb6eaf42a0a8e18b6c1ff3af7b5e12d0 SHA512 c95bc980b5aeeb4f4832cb2dbbf82adf72e4a784fcd46432fd6e6a6577ef02823ec1c4b861d07747c066050fc5040aca975e2cdc78342abab99a3d486888a25d
diff --git a/x11-wm/pekwm/pekwm-0.1.18.ebuild b/x11-wm/pekwm/pekwm-0.1.18.ebuild
new file mode 100644
index 000000000000..72519b9ed577
--- /dev/null
+++ b/x11-wm/pekwm/pekwm-0.1.18.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="A lightweight window manager initially based on aewm++"
+HOMEPAGE="
+ https://www.pekwm.org/
+ https://github.com/pekdon/pekwm
+"
+SRC_URI="
+ https://github.com/pekdon/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz
+ themes? ( https://dev.gentoo.org/~jer/${PN}-themes.tar.bz2 )
+"
+S="${WORKDIR}"/${PN}-release-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="contrib debug themes truetype xinerama"
+
+RDEPEND="media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ truetype? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ if use themes; then
+ rm "${WORKDIR}"/themes/Ace/.theme.swp || die
+ fi
+
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable truetype xft) \
+ $(use_enable xinerama) \
+ --enable-image-jpeg \
+ --enable-image-png \
+ --enable-image-xpm \
+ --enable-shape \
+ --enable-xrandr
+}
+
+src_install() {
+ default
+
+ # Install contributor scripts into doc folder
+ if use contrib; then
+ docinto contrib
+ dodoc contrib/lobo/{check.png,pekwm_autoprop.pl,pekwm_menu_config.pl} \
+ contrib/lobo/{pekwm_menu_config.pl.vars,README,uncheck.png}
+ fi
+
+ if use themes; then
+ insinto /usr/share/${PN}/themes
+ doins -r "${WORKDIR}"/themes/*
+ fi
+
+ # Insert an Xsession
+ echo -e "#!/bin/sh\n\n/usr/bin/${PN}" > "${T}"/${PN} || die
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/${PN}
+
+ # Insert a GDM/KDM xsession file
+ make_session_desktop ${PN} ${PN}
+}
+
+pkg_postinst() {
+ if use contrib ; then
+ elog "User contributed scripts have been installed into:"
+ elog "${EROOT}/usr/share/doc/${PF}/contrib"
+ fi
+}