summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/assimp/files/test-cmakelists.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/assimp/files/test-cmakelists.patch b/media-libs/assimp/files/test-cmakelists.patch
new file mode 100644
index 000000000000..9a3471bbc36a
--- /dev/null
+++ b/media-libs/assimp/files/test-cmakelists.patch
@@ -0,0 +1,35 @@
+--- test/CMakeLists.txt.old 2016-01-21 06:46:12.053363212 +0100
++++ test/CMakeLists.txt 2016-01-21 06:46:51.126697143 +0100
+@@ -1,7 +1,5 @@
+ cmake_minimum_required( VERSION 2.6 )
+
+-INCLUDE( AddGTest )
+-
+ INCLUDE_DIRECTORIES(
+ ${Assimp_SOURCE_DIR}/include
+ ${Assimp_SOURCE_DIR}/code
+@@ -47,7 +45,7 @@
+
+ SOURCE_GROUP( tests FILES ${TEST_SRCS} )
+
+-if(AddGTest_FOUND)
++if(BUILD_TESTS)
+ add_executable( unit
+ unit/CCompilerTest.c
+ unit/Main.cpp
+@@ -56,13 +54,12 @@
+ )
+
+ add_definitions(-DASSIMP_TEST_MODELS_DIR="${CMAKE_CURRENT_LIST_DIR}/models")
++target_link_libraries( unit gtest )
+
+ SET_PROPERTY( TARGET assimp PROPERTY DEBUG_POSTFIX ${CMAKE_DEBUG_POSTFIX} )
+
+ add_dependencies( unit gtest )
+ target_link_libraries( unit assimp
+- debug ${GTEST_DEBUG_LIBRARIES}
+- optimized ${GTEST_RELEASE_LIBRARIES}
+ )
+-endif(AddGTest_FOUND)
++endif(BUILD_TESTS)
+ add_subdirectory(headercheck)