summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/re2c/re2c-2.1.1-r1.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-2.1.1-r1.ebuild b/dev-util/re2c/re2c-2.1.1-r1.ebuild
index 29518e3a9d51..854354f08251 100644
--- a/dev-util/re2c/re2c-2.1.1-r1.ebuild
+++ b/dev-util/re2c/re2c-2.1.1-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="tool for generating C-based recognizers from regular expressions"
HOMEPAGE="http://re2c.org/"
SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
@@ -14,6 +16,16 @@ IUSE="debug"
PATCHES=("${FILESDIR}"/${P}-sh.patch)
+src_prepare() {
+ default
+
+ # Only needed for the sh patch
+ # Despite the patch modifying the configure directly,
+ # this is sometimes fragile and triggers maintainer mode anyway.
+ # bug #779187
+ eautoreconf
+}
+
src_configure() {
econf \
--enable-golang \