summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/agrep')
-rw-r--r--app-text/agrep/Manifest1
-rw-r--r--app-text/agrep/agrep-2.04-r1.ebuild34
-rw-r--r--app-text/agrep/agrep-2.04.ebuild33
-rw-r--r--app-text/agrep/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/app-text/agrep/Manifest b/app-text/agrep/Manifest
new file mode 100644
index 000000000000..ccfab3e105e7
--- /dev/null
+++ b/app-text/agrep/Manifest
@@ -0,0 +1 @@
+DIST agrep-2.04.tar.Z 62351 SHA256 31275a2fee28fb8966e1978d26fe8113b61ce49b39e68ddf4cad3964db72d5f8 SHA512 4524250c2c0b309243fd245efb04fa8d867f45a92b0d977b29d2ff8ec99586c16c35b8a78cdd5aeb4c529fe0270c8b1220d6ddf52d947e6181a5f04bdbed5aee WHIRLPOOL a77870cb9b08512a847acf203d6b5ccad343a9b0bff107d8d768a9d5545c01ecccf860b0e35a9be82a46bbfc5718ba963145016dc8039ab3c157ba0a824316b0
diff --git a/app-text/agrep/agrep-2.04-r1.ebuild b/app-text/agrep/agrep-2.04-r1.ebuild
new file mode 100644
index 000000000000..dee0d55744c2
--- /dev/null
+++ b/app-text/agrep/agrep-2.04-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="agrep is a tool for the fast searching of text allowing for errors in the search pattern"
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/agrep/${P}.tar.Z"
+
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 ~sparc x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ !dev-libs/tre
+ !app-misc/glimpse"
+
+src_compile() {
+ # Remove first occurace of CFLAGS so we grab the user CFLAGS
+ sed -i -e 's/^CFLAGS.*//' \
+ -e "s:\$(CFLAGS):& \$(LDFLAGS) :" Makefile || die
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin agrep || die
+ doman agrep.1 || die
+ dodoc README agrep.algorithms agrep.chronicle COPYRIGHT \
+ contribution.list || die
+}
diff --git a/app-text/agrep/agrep-2.04.ebuild b/app-text/agrep/agrep-2.04.ebuild
new file mode 100644
index 000000000000..f7bc2f671725
--- /dev/null
+++ b/app-text/agrep/agrep-2.04.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="agrep is a tool for the fast searching of text allowing for errors in the search pattern"
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/agrep/${P}.tar.Z"
+
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ !dev-libs/tre
+ !app-misc/glimpse"
+
+src_compile() {
+ # Remove first occurace of CFLAGS so we grab the user CFLAGS
+ sed -i -e 's/^CFLAGS.*//' Makefile || die
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin agrep || die
+ doman agrep.1 || die
+ dodoc README agrep.algorithms agrep.chronicle COPYRIGHT \
+ contribution.list || die
+}
diff --git a/app-text/agrep/metadata.xml b/app-text/agrep/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/app-text/agrep/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>