summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arping/files/arping-2.15-setgroups.patch')
-rw-r--r--net-analyzer/arping/files/arping-2.15-setgroups.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-analyzer/arping/files/arping-2.15-setgroups.patch b/net-analyzer/arping/files/arping-2.15-setgroups.patch
new file mode 100644
index 000000000000..59b675814814
--- /dev/null
+++ b/net-analyzer/arping/files/arping-2.15-setgroups.patch
@@ -0,0 +1,23 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,6 +35,7 @@
+ stdlib.h \
+ sys/socket.h \
+ time.h \
++grp.h \
+ sys/time.h \
+ sys/types.h \
+ sys/capability.h \
+--- a/src/arping.c
++++ b/src/arping.c
+@@ -98,6 +98,10 @@
+ #endif
+ #include <pcap.h>
+
++#if HAVE_GRP_H
++#include <grp.h>
++#endif
++
+ #include "arping.h"
+
+ #ifndef ETH_ALEN