summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/poink/poink-2.03.ebuild')
-rw-r--r--net-analyzer/poink/poink-2.03.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/poink/poink-2.03.ebuild b/net-analyzer/poink/poink-2.03.ebuild
new file mode 100644
index 000000000000..356775514c51
--- /dev/null
+++ b/net-analyzer/poink/poink-2.03.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TCP/IP-based ping implementation"
+HOMEPAGE="http://directory.fsf.org/security/system/poink.html"
+SRC_URI="http://ep09.pld-linux.org/~mmazur/poink/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-2.03-signed-char-fixup.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin poink poink6
+ newman ping.1 poink.1
+ dodoc README* ChangeLog COPYING
+}