summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/metadata.xml3
-rw-r--r--x11-terms/terminology/terminology-1.4.0.ebuild44
3 files changed, 48 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 68fc495325c5..8678ec96d460 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1 +1,2 @@
DIST terminology-1.3.2.tar.xz 4849832 BLAKE2B db03ab8d40a432e42d645a53a02b96afa37a6d238cb26bea55de6153969164e53986d70091239235ba724556feaa32bc8de68aba5fb766543f1719791f0c5ab6 SHA512 e41e413348451e0df90634af06fb49ec830f9b1454eec2601977e6e35385bd1a62a385a9ab7fc02fc6c3750f5b73785e4f40f14bb36acd58d4c296074b5f32c8
+DIST terminology-1.4.0.tar.xz 4878656 BLAKE2B 7e6b41e1057aa245c9cbcbdf164efd68cef7d3bc92706d10d100bface25a7e29468512ee690795e9f09242b644d80215239f761fe7216ea5d768f48259436778 SHA512 c7fd6605c00983e79a647b1e577868e5d2b713321164cb0ee8ef4b4a4155bf320f3e145ce91ecf1d3b0c40f28ae360b96798e47fd11accfa230932cfbd9e5c9e
diff --git a/x11-terms/terminology/metadata.xml b/x11-terms/terminology/metadata.xml
index d9a6217dd22d..acb2058998ad 100644
--- a/x11-terms/terminology/metadata.xml
+++ b/x11-terms/terminology/metadata.xml
@@ -8,4 +8,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <use>
+ <flag name="extras">Install additional testing tools</flag>
+ </use>
</pkgmetadata>
diff --git a/x11-terms/terminology/terminology-1.4.0.ebuild b/x11-terms/terminology/terminology-1.4.0.ebuild
new file mode 100644
index 000000000000..65b045e742ae
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="extras nls"
+
+RDEPEND="
+ || ( dev-libs/efl[gles2] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}