summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Psota <jasiupsota@gmail.com>2018-04-30 11:11:37 +0200
committerJan Psota <jasiupsota@gmail.com>2018-04-30 11:13:38 +0200
commit703deb0aabe58afc5ac1875b5e2d2243c8e514ae (patch)
treedfe0b267d6767ad5c52b4262c79f141433f2ae7a
parent2018-04-23 18:50:29 UTC (diff)
downloadbleeding-edge-703deb0aabe58afc5ac1875b5e2d2243c8e514ae.tar.gz
bleeding-edge-703deb0aabe58afc5ac1875b5e2d2243c8e514ae.tar.bz2
bleeding-edge-703deb0aabe58afc5ac1875b5e2d2243c8e514ae.zip
pcmanfm / libfm abi slot update + use xdg-utils instead of deprecated fdo-mime
-rw-r--r--x11-libs/libfm/libfm-9999.ebuild10
-rw-r--r--x11-misc/pcmanfm/pcmanfm-9999.ebuild12
2 files changed, 11 insertions, 11 deletions
diff --git a/x11-libs/libfm/libfm-9999.ebuild b/x11-libs/libfm/libfm-9999.ebuild
index 8c0f8e3..741d715 100644
--- a/x11-libs/libfm/libfm-9999.ebuild
+++ b/x11-libs/libfm/libfm-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools fdo-mime git-r3 vala
+inherit autotools git-r3 vala xdg-utils
DESCRIPTION="A library for file management"
HOMEPAGE="http://pcmanfm.sourceforge.net/"
EGIT_REPO_URI="https://github.com/lxde/${PN}"
LICENSE="GPL-2"
-SLOT="0/4.4.0" #copy ABI_VERSION because it seems upstream change it randomly
+SLOT="0/5.1.1" #copy ABI_VERSION because it seems upstream change it randomly
KEYWORDS=""
IUSE="+automount debug doc examples exif +gtk +gtk3 udisks vala"
@@ -119,9 +119,9 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
diff --git a/x11-misc/pcmanfm/pcmanfm-9999.ebuild b/x11-misc/pcmanfm/pcmanfm-9999.ebuild
index 5bf38cc..5cb6fb1 100644
--- a/x11-misc/pcmanfm/pcmanfm-9999.ebuild
+++ b/x11-misc/pcmanfm/pcmanfm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ is it ja kk km ko lg lt lv ms nl pa pl pt pt_BR ro ru si sk sl sr sr@latin sv
te th tr tt_RU ug uk vi zh_CN zh_TW"
PLOCALE_BACKUP="en_GB"
-inherit autotools eutils fdo-mime l10n readme.gentoo-r1
+inherit autotools eutils xdg-utils l10n readme.gentoo-r1
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}"
@@ -71,12 +71,12 @@ src_install() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
readme.gentoo_print_elog
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}