aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-05-30 19:50:52 +0300
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-05-30 19:50:52 +0300
commitbd7877994e9bad50415a6b7551d946adfd4e86ca (patch)
tree37455f483e487b411d4b7c8b2f9364b514abb018
parentdev-lang/dmd: drop 2.108.0 (diff)
downloaddlang-bd7877994e9bad50415a6b7551d946adfd4e86ca.tar.gz
dlang-bd7877994e9bad50415a6b7551d946adfd4e86ca.tar.bz2
dlang-bd7877994e9bad50415a6b7551d946adfd4e86ca.zip
dev-lang/ldc2: drop 1.36.0-r1
Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
-rw-r--r--dev-lang/ldc2/ldc2-1.36.0-r1.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/dev-lang/ldc2/ldc2-1.36.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.36.0-r1.ebuild
deleted file mode 100644
index bc995b9..0000000
--- a/dev-lang/ldc2/ldc2-1.36.0-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic multilib-build cmake llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="~amd64 ~arm64 ~x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# Upstream supports LLVM 11.0 through 17.0.
-DEPEND="
- || (
- sys-devel/llvm:17
- sys-devel/llvm:16
- sys-devel/llvm:15
- )
- <sys-devel/llvm-18:="
-IDEPEND=">=app-eselect/eselect-dlang-20140709"
-RDEPEND="
- ${DEPEND}
- ${IDEPEND}"
-
-LLVM_MAX_SLOT=17
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.100-2.106"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-src_prepare() {
- cmake_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- # We disable assertions so we have to apply the same workaround as for
- # sys-devel/llvm: add -DNDEBUG to CPPFLAGS.
- local CPPFLAGS="${CPPFLAGS} -DNDEBUG"
- # https://bugs.gentoo.org/show_bug.cgi?id=922590
- append-flags -fno-strict-aliasing
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD} $(dlang_dmdw_dcflags)"
- -DLDC_WITH_LLD=OFF
- -DCOMPILE_D_MODULES_SEPARATELY=ON
- -DLDC_ENABLE_ASSERTIONS=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- cmake_src_configure
-}
-
-d_src_compile()
-{
- cmake_src_compile
-}
-
-d_src_install() {
- cmake_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}