aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2018-11-26 11:12:08 +0100
committerGerion Entrup <gerion.entrup@flump.de>2018-11-26 11:14:46 +0100
commitc5124957a127a2fa35bd9c4b6399e56e83a20703 (patch)
tree543f7b24e80eaa9a97abb357b105d9561a1ab2d7 /dev-python
parentadd media-libs/mutagen-1.41.1 (diff)
downloadgerislay-c5124957a127a2fa35bd9c4b6399e56e83a20703.tar.gz
gerislay-c5124957a127a2fa35bd9c4b6399e56e83a20703.tar.bz2
gerislay-c5124957a127a2fa35bd9c4b6399e56e83a20703.zip
dev-python/junit2html: add for zephyr
Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/junit2html/Manifest2
-rw-r--r--dev-python/junit2html/junit2html-22.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/junit2html/Manifest b/dev-python/junit2html/Manifest
new file mode 100644
index 0000000..0bf6cd9
--- /dev/null
+++ b/dev-python/junit2html/Manifest
@@ -0,0 +1,2 @@
+DIST junit2html-v022.tar.gz 50730 BLAKE2B a961d90e0570da8f203cb978213d37890981757355f1176ea997006fc619939ddf27c0d3bbc7ac89d48dfc5f99c113e05907a72b63406e9cd98dc3568fb02baf SHA512 2c3a0662edd705c5215e5900675ac10faafef75fd58514f2ac3315eb84e8f3a5f5a60cce7a19d2bcaf350e606ce01a6a3859fe406202e46e44cc85bb553f6ea1
+EBUILD junit2html-22.ebuild 537 BLAKE2B 32b47dd6204ae6f8b6d7e8d5cee7d099782d9dbc6433eeccd8c1960c4807d57d8c49f62371a633dd91a86705e60112404dead10a2a5413648bfb7da422a59099 SHA512 b393d12c7f98f44ccc135831ffa0874406eb65149209feb85f885bdcecb87db8077d108a2a5404acc257b7e46f62019d047b1cf336e4f1138a00089e6ae74755
diff --git a/dev-python/junit2html/junit2html-22.ebuild b/dev-python/junit2html/junit2html-22.ebuild
new file mode 100644
index 0000000..6fe7efb
--- /dev/null
+++ b/dev-python/junit2html/junit2html-22.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to produce a single html file from a single junit xml file."
+HOMEPAGE="https://gitlab.com/inorton/junit2html"
+SRC_URI="https://gitlab.com/inorton/${PN}/-/archive/v0${PV}/${PN}-v0${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-v0${PV}"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"