aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2023-12-23 01:29:16 +0100
committerGerion Entrup <gerion.entrup@flump.de>2023-12-23 01:29:16 +0100
commit030a9a9ce6cf205e47d43d603708c9e0b6185240 (patch)
tree0135c4f7fea9aabeb937b88337d1461a4b96701a /gui-apps/organicmaps/files/more-3party.patch
parentsets/vim-dev: rust-analyzer is not an extra package anymore (diff)
downloadgerislay-030a9a9ce6cf205e47d43d603708c9e0b6185240.tar.gz
gerislay-030a9a9ce6cf205e47d43d603708c9e0b6185240.tar.bz2
gerislay-030a9a9ce6cf205e47d43d603708c9e0b6185240.zip
gui-apps/organicmaps: add working version
Oriented on the guru version with additional patches. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
Diffstat (limited to 'gui-apps/organicmaps/files/more-3party.patch')
-rw-r--r--gui-apps/organicmaps/files/more-3party.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/gui-apps/organicmaps/files/more-3party.patch b/gui-apps/organicmaps/files/more-3party.patch
new file mode 100644
index 0000000..b1293e8
--- /dev/null
+++ b/gui-apps/organicmaps/files/more-3party.patch
@@ -0,0 +1,47 @@
+From b77c26e242945fe06be94059b87c3c2eebdb78eb Mon Sep 17 00:00:00 2001
+From: Gerion Entrup <gerion.entrup@flump.de>
+Date: Fri, 8 Dec 2023 23:45:56 +0100
+Subject: [PATCH] cmake: use some internal libraries without external
+ alternative
+
+---
+ 3party/CMakeLists.txt | 6 +++---
+ base/CMakeLists.txt | 4 +---
+ 2 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/3party/CMakeLists.txt b/3party/CMakeLists.txt
+index bd44e1b7b8..4f5cb99807 100644
+--- a/3party/CMakeLists.txt
++++ b/3party/CMakeLists.txt
+@@ -34,11 +34,11 @@ else()
+
+ # Add pugixml library.
+ add_subdirectory(pugixml)
+-
+- # Add protobuf library.
+- add_subdirectory(protobuf)
+ endif()
+
++# Add protobuf library.
++add_subdirectory(protobuf)
++
+ add_subdirectory(agg)
+ add_subdirectory(bsdiff-courgette)
+
+diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
+index 7e762b242a..0d7d6c5d10 100644
+--- a/base/CMakeLists.txt
++++ b/base/CMakeLists.txt
+@@ -111,8 +111,6 @@ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package(Threads REQUIRED)
+ target_link_libraries(${PROJECT_NAME} INTERFACE Threads::Threads)
+
+-if (NOT WITH_SYSTEM_PROVIDED_3PARTY)
+- target_include_directories(${PROJECT_NAME} PRIVATE "${OMIM_ROOT}/3party/fast_double_parser/include")
+-endif()
++target_include_directories(${PROJECT_NAME} PRIVATE "${OMIM_ROOT}/3party/fast_double_parser/include")
+
+ omim_add_test_subdirectory(base_tests)
+--
+2.41.0
+