aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2017-09-28 19:04:50 +0200
committerGerion Entrup <gerion.entrup@flump.de>2017-09-28 19:04:50 +0200
commit6862bb26a782b530b040a10baae1c89cbcbc70ba (patch)
tree0e588b9e6569fd85bf76e8ae84b84a660fa3c689 /media-sound
parentmedia-sound/calf: dependency for ladish (diff)
downloadgerislay-6862bb26a782b530b040a10baae1c89cbcbc70ba.tar.gz
gerislay-6862bb26a782b530b040a10baae1c89cbcbc70ba.tar.bz2
gerislay-6862bb26a782b530b040a10baae1c89cbcbc70ba.zip
media-sound/fluidsynth: dependency on ladish
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fluidsynth/Manifest3
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.6-r2.ebuild69
-rw-r--r--media-sound/fluidsynth/metadata.xml11
3 files changed, 83 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
new file mode 100644
index 0000000..a5bb018
--- /dev/null
+++ b/media-sound/fluidsynth/Manifest
@@ -0,0 +1,3 @@
+DIST fluidsynth-1.1.6.tar.gz 958735 SHA256 50853391d9ebeda9b4db787efb23f98b1e26b7296dd2bb5d0d96b5bccee2171c SHA512 2dcb8a8a1634273cc93c45b6e21b87ac45a023c768cffdadda0a4e611eab8d5bbea0e1ba59e5f147488054cfa6fcaf561399ae275a665c76082b8738a80778bb WHIRLPOOL c3ede7f1218b5f445cf3537ed52dd32ebdcf50c44774431323b17dda963e334f80ec255e086380007dad69b4f3338aacb22ef90c10904f57d946f4573ced869b
+EBUILD fluidsynth-1.1.6-r2.ebuild 2155 SHA256 77cee9a87f6aa4c1a4d05338e0f77c636101bcbd981238a03780c40c15b1b0e9 SHA512 14cec57c43812f079778129773d08e8f461b0f2a5c104ee3e277c68e28e9bc4c28780e5674f7f2e28056e9552a13091ca0526f552e04fc9309d367c51b52c72f WHIRLPOOL 2921814f1d916a8e04e1dc38f0db21a89535e192d281a20c396d3eb35865c1c1d19738954619cc6536dd499173e9ffa22f3ae86104d048f42cd496a1de6c1a70
+MISC metadata.xml 333 SHA256 b5cb2f75ca91b1eb78a56d55d72c3652b018d263eb22acf716efc02986ae6f84 SHA512 016dcb0abac11ce0dedc95e5a8998b3c82f3c31c17a7d9c34baa095854c1cab7b2c0a77e091a754ed653705245473800f7356fb1f6ae7653b53582e42ca7a58d WHIRLPOOL 13559a60b2d7bf1f85b9a12844478321339b66e5ae77a7a968eb64afefc154df4416d96ea8617e472635706e47c7cf84eddc44fcc9b1081df609f169e771a89d
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.6-r2.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.6-r2.ebuild
new file mode 100644
index 0000000..28b8d27
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.6-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa dbus debug examples jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}]
+ lash? ( || ( >=media-sound/lash-0.5.4-r2[${MULTILIB_USEDEP}] media-sound/ladish[${MULTILIB_USEDEP}] ) ) )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}]
+ >=media-libs/ladspa-cmt-1.16-r3[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ portaudio? ( >=media-libs/portaudio-19_pre20111121-r1[${MULTILIB_USEDEP}] )
+ readline? ( >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}] )
+ sndfile? ( >=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_configure() {
+ # autotools based build system has AC_CHECK_LIB(pthread, pthread_create) wrt
+ # bug #436762
+ append-flags -pthread
+
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ dodoc AUTHORS NEWS README THANKS TODO doc/*.txt
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/*.c
+ fi
+}
diff --git a/media-sound/fluidsynth/metadata.xml b/media-sound/fluidsynth/metadata.xml
new file mode 100644
index 0000000..439f7cd
--- /dev/null
+++ b/media-sound/fluidsynth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fluidsynth</remote-id>
+ </upstream>
+</pkgmetadata>