aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libquotient/files/libquotient-0.8.0-no-android.patch')
-rw-r--r--net-libs/libquotient/files/libquotient-0.8.0-no-android.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
new file mode 100644
index 0000000..19dca18
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0a32ee4e..4200f29c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -387,7 +387,9 @@ install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_NAME}/${QUOTIENT_LIB_NAME}ConfigVersion.cmake"
+ DESTINATION ${CMakeFilesLocation}
+ )
+-install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++if (ANDROID)
++ install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++endif ()
+
+ if (WIN32)
+ install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)