summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-17 16:19:40 -0700
committerJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-17 16:23:27 -0700
commitd5254ccd8093f37459a691f9ebfa902f715facdb (patch)
treeab6ac33de3864c4264f90b1d520748c6ee6edab2
parentgui-apps/hyprlock: Add ebuild (diff)
downloadjohnmh-d5254ccd8093f37459a691f9ebfa902f715facdb.tar.gz
johnmh-d5254ccd8093f37459a691f9ebfa902f715facdb.tar.bz2
johnmh-d5254ccd8093f37459a691f9ebfa902f715facdb.zip
dev-libs/hyprlang: Add ebuild
Signed-off-by: John M. Harris, Jr. <johnmh@johnmh.me>
-rw-r--r--dev-libs/hyprlang/Manifest1
-rw-r--r--dev-libs/hyprlang/hyprlang-9999.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/hyprlang/Manifest b/dev-libs/hyprlang/Manifest
new file mode 100644
index 0000000..cfb7d50
--- /dev/null
+++ b/dev-libs/hyprlang/Manifest
@@ -0,0 +1 @@
+EBUILD hyprlang-9999.ebuild 619 BLAKE2B cdbbeb30973e5a020c18c719c627fcadf413f70950f5d6abc0fa6ce2228750913246090ead7384a200b0ab0668e1d91bc86d70fbdaf705932f3047f26fd13202 SHA512 62f60842f784f6015bdab9c7cd93a9fe834b6ebcb38ac2f31ca5cab1c1e426ae6b7d9f9729965504bb731f4ae3799d8bec769a223dc2ce8d7921b09de727f2d3
diff --git a/dev-libs/hyprlang/hyprlang-9999.ebuild b/dev-libs/hyprlang/hyprlang-9999.ebuild
new file mode 100644
index 0000000..08ee820
--- /dev/null
+++ b/dev-libs/hyprlang/hyprlang-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023-2024 Gentoo Authors
+# Copyright 2024 John M. Harris, Jr.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Official implementation library for the hypr config language"
+HOMEPAGE="https://github.com/hyprwm/hyprlang"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"