summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/hyprutils/hyprutils-9999.ebuild')
-rw-r--r--gui-libs/hyprutils/hyprutils-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/gui-libs/hyprutils/hyprutils-9999.ebuild b/gui-libs/hyprutils/hyprutils-9999.ebuild
new file mode 100644
index 0000000..f58baa5
--- /dev/null
+++ b/gui-libs/hyprutils/hyprutils-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Copyright 2024 John M. Harris, Jr.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland utilities library used across the ecosystem"
+HOMEPAGE="https://github.com/hyprwm/hyprutils"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"