aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2020-10-18 21:07:18 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2020-10-18 21:07:18 +0100
commit11fd2934c84ca8cdfa8abeba4bff9e9af7fd035d (patch)
treecddce9c6666aeabb6effa54c5f6307b4160a7595 /net-misc
parentUpdate visual-studio-code (diff)
downloadssnb-11fd2934c84ca8cdfa8abeba4bff9e9af7fd035d.tar.gz
ssnb-11fd2934c84ca8cdfa8abeba4bff9e9af7fd035d.tar.bz2
ssnb-11fd2934c84ca8cdfa8abeba4bff9e9af7fd035d.zip
Add oidc-agent
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/oidc-agent/Manifest3
-rw-r--r--net-misc/oidc-agent/metadata.xml9
-rw-r--r--net-misc/oidc-agent/oidc-agent-3.3.5.ebuild63
l---------net-misc/oidc-agent/oidc-agent-9999.ebuild1
4 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/Manifest b/net-misc/oidc-agent/Manifest
new file mode 100644
index 0000000..e049941
--- /dev/null
+++ b/net-misc/oidc-agent/Manifest
@@ -0,0 +1,3 @@
+EBUILD oidc-agent-3.3.5.ebuild 1395 BLAKE2B 06139a6a9746be3feb298049648cded3376f52756cb5d4d590b4e30cb3e2d56500c93cf0eb124de71bae7ee2508d8bf1fc0f02269d1bfd69515f4daad7c6c955 SHA512 0877ca52bfbffda643bdc4aff3cfb74786baa76af998019866bcf26d8d4f7cc47625ce45cfd605e8cb101caffb80d1bbaef8f2005188175212f30f6d77968b17
+EBUILD oidc-agent-9999.ebuild 1395 BLAKE2B 06139a6a9746be3feb298049648cded3376f52756cb5d4d590b4e30cb3e2d56500c93cf0eb124de71bae7ee2508d8bf1fc0f02269d1bfd69515f4daad7c6c955 SHA512 0877ca52bfbffda643bdc4aff3cfb74786baa76af998019866bcf26d8d4f7cc47625ce45cfd605e8cb101caffb80d1bbaef8f2005188175212f30f6d77968b17
+MISC metadata.xml 386 BLAKE2B 7928a64e2da68cf0d9b29beb0b4cd4c72843cd52c537bbf1ac159b273162825258a062b8fcd6cd64ed23d316c212d325a49381d587b5e39ae8fb2b67686b1fba SHA512 2bcc0d450bc459bd5204c81e7f8aec0075a72c1f0781ab4272067ae734f9380f8d55501f883827133d98859ac0a96039a94f48a5805aed558e03c023ff76f74b
diff --git a/net-misc/oidc-agent/metadata.xml b/net-misc/oidc-agent/metadata.xml
new file mode 100644
index 0000000..989d5e5
--- /dev/null
+++ b/net-misc/oidc-agent/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>samuelbernardo.mail@gmail.com</email>
+ <name>Samuel Bernardo</name>
+ <description>A set of tools to manage OpenID Connect tokens and make them easily usable from the command line</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/oidc-agent/oidc-agent-3.3.5.ebuild b/net-misc/oidc-agent/oidc-agent-3.3.5.ebuild
new file mode 100644
index 0000000..96f1f14
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-3.3.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=7
+
+inherit eutils git-r3
+
+DESCRIPTION="A set of tools to manage OpenID Connect tokens and make them easily usable from the command line"
+HOMEPAGE="https://github.com/indigo-dc/oidc-agent"
+RTAG="_so"
+if [[ ${PV} == *9999* ]];then
+ EGIT_REPO_URI="https://github.com/indigo-dc/oidc-agent"
+ KEYWORDS=""
+ #EGIT_SUBMODULES=( '*' )
+ EGIT_CHECKOUT_DIR=${WORKDIR}/${P}
+else
+ EGIT_REPO_URI="https://github.com/LIP-Computing/oidc-agent"
+ EGIT_BRANCH="v${PV}${RTAG}"
+ #EGIT_SUBMODULES=( '*' )
+ EGIT_CHECKOUT_DIR=${WORKDIR}/${P}
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-apps/help2man
+ "
+RDEPEND="${DEPEND}
+ net-libs/libmicrohttpd
+ sys-libs/libseccomp
+ app-crypt/libsecret
+ dev-libs/libsodium
+ net-misc/curl[openssl]
+ "
+
+PATCHES=( )
+
+if [[ ${PV} != *9999* ]];then
+ src_prepare(){
+ if [ -e "${FILESDIR}/${PV}/*.patch" ]; then
+ EPATCH_OPTS="-p0" epatch "${FILESDIR}/${PV}/*.patch"
+ fi
+ if [ ! -z ${PATCHES} ]; then
+ epatch ${PATCHES}
+ fi
+ eapply_user
+ default
+ }
+fi
+
+src_compile(){
+ emake -j1 PREFIX="${D}" || die "Failed at compile phase"
+}
+
+src_install(){
+ emake install_lib PREFIX="${D}" || die "Failed in install_lib target"
+ emake install PREFIX="${D}" || die "Failed in install_lib target"
+ insinto usr/share/licenses/${PN}
+ doins LICENSE
+}
diff --git a/net-misc/oidc-agent/oidc-agent-9999.ebuild b/net-misc/oidc-agent/oidc-agent-9999.ebuild
new file mode 120000
index 0000000..ba1fd6e
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-9999.ebuild
@@ -0,0 +1 @@
+oidc-agent-3.3.5.ebuild \ No newline at end of file