summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2024-02-19 17:28:54 -0500
committerPhilip Miess <Philip_Miess@yahoo.com>2024-02-19 17:28:54 -0500
commitb85a87ab19083eec873d23f60cb09e8f2c832162 (patch)
tree79088cdf76bdb78db875db030047eba32c2b99f3
parenteapi bump revenge of the titans to 7 (diff)
downloadsuperposition-b85a87ab19083eec873d23f60cb09e8f2c832162.tar.gz
superposition-b85a87ab19083eec873d23f60cb09e8f2c832162.tar.bz2
superposition-b85a87ab19083eec873d23f60cb09e8f2c832162.zip
add ftl version from humble bundle
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
-rw-r--r--games-roguelike/FTL/FTL-1.6.12.0-r1.ebuild70
-rw-r--r--games-roguelike/FTL/Manifest3
-rw-r--r--games-roguelike/FTL/metadata.xml11
3 files changed, 84 insertions, 0 deletions
diff --git a/games-roguelike/FTL/FTL-1.6.12.0-r1.ebuild b/games-roguelike/FTL/FTL-1.6.12.0-r1.ebuild
new file mode 100644
index 0000000..c1b8d2d
--- /dev/null
+++ b/games-roguelike/FTL/FTL-1.6.12.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop wrapper
+
+DESCRIPTION="Faster Than Light: A spaceship simulation real-time roguelike-like game"
+HOMEPAGE="https://subsetgames.com/ftl.html"
+SRC_URI="FTL.${PV}.Linux.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="all-rights-reserved Boost-1.0 free-noncomm MIT bundled-libs? ( FTL LGPL-2.1 ZLIB libpng )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+
+RESTRICT="fetch bindist splitdebug"
+
+RDEPEND="
+ sys-devel/gcc[cxx]
+ virtual/opengl
+ !bundled-libs? (
+ media-libs/devil[png]
+ media-libs/freetype:2
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ sys-libs/zlib
+ )
+"
+
+QA_PREBUILT="
+ opt/${PN}/bin/${PN}
+ opt/${PN}/lib/*
+"
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your DISTDIR directory."
+ einfo
+}
+
+src_prepare() {
+ default
+
+ if ! use bundled-libs ; then
+ # no system lib for libbass available
+ find data/${ARCH}/lib -type f \! -name "libbass*" -delete || die
+ fi
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ insinto ${dir}
+ doins -r data/resources
+
+ exeinto ${dir}/bin
+ doexe data/${ARCH}/bin/${PN}
+ exeinto ${dir}/lib
+ doexe data/${ARCH}/lib/*.so*
+
+ make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
+ make_desktop_entry ${PN} "Faster Than Light" "/usr/share/pixmaps/FTL.bmp"
+
+ newicon data/resources/exe_icon.bmp FTL.bmp
+
+ docinto html
+ dodoc ${PN}_README.html
+}
diff --git a/games-roguelike/FTL/Manifest b/games-roguelike/FTL/Manifest
new file mode 100644
index 0000000..9580f09
--- /dev/null
+++ b/games-roguelike/FTL/Manifest
@@ -0,0 +1,3 @@
+DIST FTL.1.6.12.0.Linux.zip 243100207 BLAKE2B 82422df2943982de38636afd47327af912f269a42c3cef115d08f0617b28b100a24b9bbc9c6a6528f2ed210d58982afce9639848bd33cd7eff41d7cdd296eacb SHA512 9daf0712897a79b8301ecca40a86e4e8c6676cb74fd61e832f570727aed0dce84174702651eadb2267625d5058fa689a49c2e4d14556e66a2baa832784ad9948
+EBUILD FTL-1.6.12.0-r1.ebuild 1474 BLAKE2B 4fd31a9fce8d1d3243d652b7e04e43613a47f0f2f42a33de0f6a371e5ca9ead9df3c7f149f3482d074f924abfe91379846a8be0a70b4bfadfd9ff4faf90f5ddb SHA512 05bdf795237f50e7aa97b8af97f11084e00c7829286a22744f2f48d107b262187507589b63163e2a7d5e14f142068fb6356fd0f6fbb4eca144702577d9d746b9
+MISC metadata.xml 327 BLAKE2B 5564d59d6bb745306f4ebf8fad1abed440fc8d9358608463174ea1eb753afbb77d813931bfd5aebd443a725ff7553678ab1364d5e3472de92e51c11e3542338e SHA512 3c40fa51a0d5dd60a42d22ce7eaa5c4fbbfae126201759243df1785fc686ad8096015fbbf82d733ad634804b0861d4538749a6335ebbaee59f432ceb7db6d90f
diff --git a/games-roguelike/FTL/metadata.xml b/games-roguelike/FTL/metadata.xml
new file mode 100644
index 0000000..14d02f0
--- /dev/null
+++ b/games-roguelike/FTL/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">Use bundled libraries.</flag>
+ </use>
+</pkgmetadata>