summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-06-18 20:26:08 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-06-18 20:26:08 -0400
commit70c083a90781be522b09b7687c2077a8c43073e4 (patch)
treef256f6939578e3157554d483bd15779523f1afe2 /app-crypt
parentadd 2.3.5 (diff)
downloadsuperposition-70c083a90781be522b09b7687c2077a8c43073e4.tar.gz
superposition-70c083a90781be522b09b7687c2077a8c43073e4.tar.bz2
superposition-70c083a90781be522b09b7687c2077a8c43073e4.zip
gorilla-1.5.3.7
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gorilla/Manifest4
-rw-r--r--app-crypt/gorilla/files/gorilla-script-distdir-1.patch17
-rw-r--r--app-crypt/gorilla/gorilla-1.5.3.7.ebuild40
-rw-r--r--app-crypt/gorilla/metadata.xml11
4 files changed, 72 insertions, 0 deletions
diff --git a/app-crypt/gorilla/Manifest b/app-crypt/gorilla/Manifest
new file mode 100644
index 0000000..dd05d5c
--- /dev/null
+++ b/app-crypt/gorilla/Manifest
@@ -0,0 +1,4 @@
+AUX gorilla-script-distdir-1.patch 503 SHA256 cefae52454d98bca728e2be003623495bdc6fe8b6a2c6e4e730cc9f4526b5365 SHA512 d39601d0fbd2e25eb540fce4b837fbc86782d643577389a518312a23249c8930a3a784d03ea6a65753135660bdeed425b4906812f420b9f625e613ca2fb237c6 WHIRLPOOL 1b2ba36518130845979fa97b59cb443376eca1e8a1bbb37fde478f4a1692aa084720e3aabe6a411aacb248fd342896aef838ebe51b4c76c6b6b5dd12f7ba57c2
+DIST gorilla-1.5.3.7.tar.gz 5008679 SHA256 cb55c0134451a26dab10826396752f0e8d5f9fc6af3a85ee75e7dfa914f53720 SHA512 013aaf1a47dac6490aaf11e6598142069d1d32a2a9c8fcf6100c8f9d0a3233e21250510d95ff10930b4dc3b19c065c34a7eae234790f4068cb4c598ab835efc4 WHIRLPOOL ebf1ae84c40a848a95c2f46dd3d7a410518fffbb0e81899ff6eedc56d4dd9b370c032ee1886d375ab70f993798693079029685831f75d181743f11d1964a10a7
+EBUILD gorilla-1.5.3.7.ebuild 778 SHA256 ff51dffde430bc2ddab741364029a7f41d794a65b01ea6297e37ad3981c69777 SHA512 b137ab3c328a65a4c7d892a3cb14de66f5ff9b67a299c8df71de8eb7c73c1e40d4e6a9474f36a41b035c0392aeeb71983f472a7f98ac25cc668cb276f5434595 WHIRLPOOL 3bf9ce7c56302259e414180eb4e4fe83329bfac47146d400ac4a91266f5d6a20ec754e9f4e33eb42c23903b7410e9a07a4764d040059172fca7744e3c8afc01f
+MISC metadata.xml 334 SHA256 c977e213ec24ca6de82f0139fd8348acfc6aeea7c3dbf9b8050b23965cfb0762 SHA512 82e606fd71fd8dd152b2e3a0638a6d503789226dcf0fa89d25066af33ae8f648da132578bfa506c172596b0a265590428b6444bdeda54d98dc7f1e80b5939b54 WHIRLPOOL 7df375cc943b9443fcec768dc9bc54f923779e3f852f03505acfcfdf7b97a85443c8a66364d67fd3096a6721f4eccbb63be93f08b9d86ca917c845fd23c8e861
diff --git a/app-crypt/gorilla/files/gorilla-script-distdir-1.patch b/app-crypt/gorilla/files/gorilla-script-distdir-1.patch
new file mode 100644
index 0000000..e18fcd8
--- /dev/null
+++ b/app-crypt/gorilla/files/gorilla-script-distdir-1.patch
@@ -0,0 +1,17 @@
+--- gorilla-1.4/gorilla.in 2006-07-14 13:29:33.000000000 -0400
++++ gorilla-1.4/gorilla.in.new 2006-07-14 13:33:01.000000000 -0400
+@@ -1,10 +1,13 @@
+ #! /bin/sh
+ # the next line restarts using wish \
+ exec @wish@ "$0" ${1+"$@"}
++
+ set myName [info script]
++set myGorilla /opt/gorilla-1.4/gorilla.tcl
++
+ if {![catch {
+ set linkName [file readlink $myName]
+ }]} {
+ set myName $linkName
+ }
+-source [file join [file dirname $myName] gorilla.tcl]
++source [file join [file dirname $myName] $myGorilla]
diff --git a/app-crypt/gorilla/gorilla-1.5.3.7.ebuild b/app-crypt/gorilla/gorilla-1.5.3.7.ebuild
new file mode 100644
index 0000000..2348ecc
--- /dev/null
+++ b/app-crypt/gorilla/gorilla-1.5.3.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Password Safe in secure way with GUI interface"
+HOMEPAGE="https://github.com/zdia/gorilla/wiki"
+SRC_URI="https://github.com/zdia/gorilla/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/tcl-8.4.19:0
+ >=dev-lang/tk-8.4.19:0
+ dev-tcltk/iwidgets
+ dev-tcltk/bwidget"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-script-destdir.patch
+}
+
+src_configure() {
+ ./configure || die "econf failed"
+}
+src_compile() { :; }
+
+src_install() {
+ PREFIX="/opt/${P}"
+
+ insinto ${PREFIX}
+ doins -r gorilla.tcl isaac.tcl twofish sha1 blowfish pwsafe pics
+
+ dobin gorilla
+}
diff --git a/app-crypt/gorilla/metadata.xml b/app-crypt/gorilla/metadata.xml
new file mode 100644
index 0000000..a01eddb
--- /dev/null
+++ b/app-crypt/gorilla/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zdia/gorilla</remote-id>
+ </upstream>
+</pkgmetadata>