summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2019-11-02 12:57:22 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2019-11-02 12:57:22 -0400
commitb3a80ba13ba3008264ec34de66ad3365ffe7e3b8 (patch)
tree34c0b9596e60440642f30485af244698c1c5d5c8 /app-text/rig
parentsys-apps/0install: a new version 2.3.6 (diff)
downloadsuperposition-b3a80ba13ba3008264ec34de66ad3365ffe7e3b8.tar.gz
superposition-b3a80ba13ba3008264ec34de66ad3365ffe7e3b8.tar.bz2
superposition-b3a80ba13ba3008264ec34de66ad3365ffe7e3b8.zip
add rig
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'app-text/rig')
-rw-r--r--app-text/rig/Manifest4
-rwxr-xr-xapp-text/rig/files/rig-1.11-useDestDirAndImportMemcpy.patch23
-rw-r--r--app-text/rig/metadata.xml14
-rw-r--r--app-text/rig/rig-1.11.ebuild50
4 files changed, 91 insertions, 0 deletions
diff --git a/app-text/rig/Manifest b/app-text/rig/Manifest
new file mode 100644
index 0000000..76ad669
--- /dev/null
+++ b/app-text/rig/Manifest
@@ -0,0 +1,4 @@
+AUX rig-1.11-useDestDirAndImportMemcpy.patch 674 BLAKE2B 92c64551d8ca030a21c0a33e993980583c96064ac7f0a8040f95041cc76dbc25aa7094f638f58a5e9797c97310d73b2aa16d9cc45a0b2e774fce270cc3eca21d SHA512 958e13d420b5c91506b953a30be662d459d0c53faab36912a58658356ab019107b6b6ec1242ef23bf2e5ba03eb18e1a4c5170fca494a295272f855bbf797baba
+DIST rig-1.11.tar.gz 23112 BLAKE2B 4682581f4d0150040db29371a7d0fbb6b63072513038de37ad52195a2b83ef671d15a00e1024bc32b82c847af750d57a96ff6a6cdb08ed288e0d9d05823be445 SHA512 95bab873404fd4498f7895026b7cdda5b182dd3c33a17c4ad81389f5ed6cc0e9429cd1abaa51a023fedc472c611a66674c698d23b57515ed30d7f92e5f280b87
+EBUILD rig-1.11.ebuild 973 BLAKE2B d8bfc1034262a6407fbe680c3b4736acaacbf13e62b8d91d3b1c1faee86f94d37c7d468a2ba4f95601ecad65b5caa24fd98315d71f7d91ce7d87377f2d8a3b6e SHA512 9a66a36b9c686d1a6e19c15fb8c2b335b31b70a9f7a13e7ce5a826cdb445bc488d8bb3f98173e58bd78c1e040f5576788d3a9846f101cae751e36fa0bf19e888
+MISC metadata.xml 402 BLAKE2B 93231d98ea75439ff9eb1713ab8a6bcd62142b5c01109a17715f9d6710ac90477a2f6546614c25a4e2af4cfa8af52e5035d4e6dfc2e458b11591e154d64921db SHA512 562bb78240696acf97707ce309bcd967b0608d0b90af26763b300c5aaefd8c68ece65dabfc8e13d72b00d2ce6785e83c36dcf372d2176286a47de62dd464eb65
diff --git a/app-text/rig/files/rig-1.11-useDestDirAndImportMemcpy.patch b/app-text/rig/files/rig-1.11-useDestDirAndImportMemcpy.patch
new file mode 100755
index 0000000..415fbbd
--- /dev/null
+++ b/app-text/rig/files/rig-1.11-useDestDirAndImportMemcpy.patch
@@ -0,0 +1,23 @@
+Use DestDir for install, dont install into /usr/local,
+and #include cstring for memcpy to fix compilation error
+FROM:Phil Miess <pmiess@yahoo.com>
+Bug found by pmiess
+
+--- before/Makefile 2002-06-04 22:07:50.000000000 -0400
++++ after/Makefile 2019-11-02 07:28:13.787725115 -0400
+@@ -1,4 +1,4 @@
+-PREFIX=/usr/local
++PREFIX=$(DESTDIR)/usr
+ BINDIR=${PREFIX}/bin
+ MANDIR=${PREFIX}/man
+ DATADIR=${PREFIX}/share/rig
+--- before/rig.cc 2006-04-23 10:42:22.000000000 -0400
++++ after/rig.cc 2019-11-01 16:52:47.025118177 -0400
+@@ -21,6 +21,7 @@
+ #include <fstream>
+ #include <vector>
+ #include <string>
++#include <cstring>
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <time.h>
diff --git a/app-text/rig/metadata.xml b/app-text/rig/metadata.xml
new file mode 100644
index 0000000..a7adb80
--- /dev/null
+++ b/app-text/rig/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription lang="en">
+A program that generates fake identities.
+RIG comes with the top 1000 names from the US census at
+http://www.census.gov/genealogy/names/
+</longdescription>
+<use>
+ <flag name="devrandom">
+ Use /dev/random for randomness
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/app-text/rig/rig-1.11.ebuild b/app-text/rig/rig-1.11.ebuild
new file mode 100644
index 0000000..382e455
--- /dev/null
+++ b/app-text/rig/rig-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="generate random, yet real-looking, personal data"
+HOMEPAGE="https://sourceforge.net/projects/rig/ "
+SRC_URI="https://sourceforge.net/projects/rig/files/rig/1.11/rig-1.11.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+devrandom"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-useDestDirAndImportMemcpy.patch"
+)
+
+DOCS=( "README" "Changlelog" "rig.6" )
+
+src_configure() {
+ if use devrandom ; then
+ append-cxxflags "-DDEVRANDOM"
+ fi
+}
+
+src_compile() {
+ sed -i -e "s:g++ :$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} :" Makefile \
+ || die "sed fix failed. Uh-oh..."
+ emake
+ echo 'hello'
+}
+
+src_install() {
+ echo 'hi'
+ dodir /usr/bin
+ dodir /usr/man
+ dodir /usr/share/rig
+
+ if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
+ emake DESTDIR="${D}" install
+ fi
+ einstalldocs
+}