summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2019-01-28 16:17:51 -0500
committerPhilip Miess <Philip_Miess@yahoo.com>2019-01-28 16:17:51 -0500
commit4a9e1ff4d966a4b230c37e4cc15ad4cbe84382fe (patch)
tree04a9b1f03c8dba7423945cfc3ac3b566595b8156 /dev-ml/obus
parentadd obus remove build time deps from RDEPENDS (diff)
downloadsuperposition-4a9e1ff4d966a4b230c37e4cc15ad4cbe84382fe.tar.gz
superposition-4a9e1ff4d966a4b230c37e4cc15ad4cbe84382fe.tar.bz2
superposition-4a9e1ff4d966a4b230c37e4cc15ad4cbe84382fe.zip
add obus 1.8
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'dev-ml/obus')
-rw-r--r--dev-ml/obus/Manifest6
-rw-r--r--dev-ml/obus/metadata.xml7
-rw-r--r--dev-ml/obus/obus-1.1.8.ebuild42
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-ml/obus/Manifest b/dev-ml/obus/Manifest
index 3a50415..c7007f4 100644
--- a/dev-ml/obus/Manifest
+++ b/dev-ml/obus/Manifest
@@ -1,2 +1,4 @@
-DIST obus-1.1.tar.gz 402352 RMD160 83a85e65da4fd17fbfe8810f0f7037a6d3ba64dc SHA1 b04855d5b060831255d1f0e3a10281b2776db43c SHA256 af7b0b9f0d8d9084a8a092a1bc6bf6113c102474d45865d64bb37a761ab6ecaf
-EBUILD obus-1.1.ebuild 719 RMD160 472fe6fb65a61213eea6a2963ef576b78bb2c285 SHA1 bb068b02c91ff6bc3d52820682053029120a5457 SHA256 ccd74251b08e7e8c52166c9623f63530edde89c0f27a891637927cd5b9afcfd9
+DIST obus-1.1.8.tar.gz 169409 BLAKE2B 9dad35a4a5cc7a22ced1c03d43f754fa5efc26a0bcf152012814cfedffc8eda41feebff5602353430c3830c43243d3b1df211377642355d0fc2102d15d7218cd SHA512 2ec07ec5681a0faa2e6e5da66ffa53664bf6fe725303ad3097302256ff8a6a8114fb7ff7916cc7c41123d4304493edff926931856b61044273a1027220205e82
+DIST obus-1.1.tar.gz 402352 BLAKE2B 577372b59d5ed2d752af1143c04f92e66e142172a4bdc0d08647b998352eafb3df66681287eb5dcf4854c62b1cc815d2c72052aad819aea386753baba5176d77 SHA512 be7e4e02ae2c6c3df3a69cdde2de7a02dd22e078cc5e997a2c4497bfaa2461c765edccbe995beb23b8671a7b3ffdbc1d05522073cd66550ff4295f73804afd14
+EBUILD obus-1.1.8.ebuild 826 BLAKE2B 5ff78d895133a47677f289d41e3a0107a3f406dd7d00243740cd37d969225262a02513ec0a59e3fc3dc2d071b98d5d6fa3664b176b25788105e7a8736b5b16f6 SHA512 0f19c5fa5216ff7dc3a20fd0e6729a439fc83bca461df4b5961ea7779a64431c4cf940944aadab1eb5d58aa5706bda8b58dbf1d8a540bec67803edbfe9da6dd6
+EBUILD obus-1.1.ebuild 719 BLAKE2B d220dcab1c2a4d19bf267ebfea0ca60f164a1478268bad261be0a6eee03705850779a8b8c3ac976dc94aa942a9983fcf74be71b16d6f6c26c1bbc5d3284ef97f SHA512 06ae52d8738f37136662203d62f12ccc271e9eb7eb30e46a3a0dae68895e04a82df36befa4991ac50f8afb2aa188d6615ef3dca7f9983d0902a792fe3a7da310
diff --git a/dev-ml/obus/metadata.xml b/dev-ml/obus/metadata.xml
new file mode 100644
index 0000000..46d340f
--- /dev/null
+++ b/dev-ml/obus/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/obus/obus-1.1.8.ebuild b/dev-ml/obus/obus-1.1.8.ebuild
new file mode 100644
index 0000000..ed4953d
--- /dev/null
+++ b/dev-ml/obus/obus-1.1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit findlib oasis
+
+DESCRIPTION="OBus is a pure ocaml implementation of DBus"
+HOMEPAGE="https://github.com/diml/obus"
+SRC_URI="https://github.com/diml/obus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RESTRICT="test"
+
+COMMEN_DEPEND="
+>=dev-lang/ocaml-4.02.3[ocamlopt?]
+>=dev-ml/lwt-2.7[ocamlopt?]
+dev-ml/lwt_react[ocamlopt?]
+dev-ml/react
+dev-ml/type-conv[ocamlopt?]
+dev-ml/xmlm"
+DEPEND="${COMMEN_DEPEND}
+ dev-ml/ocamlbuild[ocamlopt?]
+ dev-ml/oasis[ocamlopt?]"
+RDEPEND="${COMMEN_DEPEND}"
+
+src_configure() {
+ oasis_src_configure
+}
+
+# Fix tests
+#src_test() {
+# dbus-launch emake -j1 test || die "make test failed"
+#}
+
+src_install() {
+ findlib_src_install
+}