summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2020-04-12 22:28:20 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2020-04-12 22:28:20 -0400
commit280907443c9515ba0ca0a3bc8aaa4fc0f248208d (patch)
treef29a2cd2ed4d22db103753e0207faa9a6b246c95 /dev-ml
parentremove signature for uncommited file (diff)
downloadsuperposition-280907443c9515ba0ca0a3bc8aaa4fc0f248208d.tar.gz
superposition-280907443c9515ba0ca0a3bc8aaa4fc0f248208d.tar.bz2
superposition-280907443c9515ba0ca0a3bc8aaa4fc0f248208d.zip
yojson version bump
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/yojson/Manifest2
-rw-r--r--dev-ml/yojson/yojson-1.7.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index f046c2e..72ea8de 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1,3 +1,5 @@
DIST yojson-1.4.0.tar.gz 26197 BLAKE2B c7d1a9d47f448995b31cd7631f64dec29e65b1f141854092bfe186a58c28b96c5c7f246f7e4ab4563dfcd84776904d4af77bbcbdc4e149229fbde339bd92df9f SHA512 dc019ecf0387299282c3df9a548456d2529993241911a83acb14f2361ed14886e5ebebe415773b6bc718cb0b12a25529184f3b5b62c71b42960fbd62e1c63bf6
+DIST yojson-1.7.0.tar.gz 29704 BLAKE2B edbd7f66d69a85880fc8ee9bb25a993744a310887024f7af63665ba8f5067f1b9383ec4d6dd5f4ca3376d698665a8f605c078f7597ddd4e71857c1a20143c2e5 SHA512 25eedb64e4bf7c7e8d5a5a115812cd502540afbdeb7c947da3a14e5968aa0a7db8ab402425662571d8935b9cd6a19796ce81dd80a65dc614f156626c60e7036e
EBUILD yojson-1.4.0.ebuild 687 BLAKE2B 6fc3c22e1993b303ff796d03330accba6ff66bad67a9327b49935d3971c67973fe99306564a0883e5ff81caf315ea022cfe5ca95289c470a4d095f208a3dab1d SHA512 1edfac963eb80e38d2ba9895737e4cd97f5b12ba357ff2e02819a406f6b60ff3f52109ce596e8e3935d0603faaaeb0bf901447f3ec961009b9453f5ee71b82bd
+EBUILD yojson-1.7.0.ebuild 704 BLAKE2B e85037e1cb75687b87e91da7fcaa4aa95febf54b2eff257775db9f97f16142f64213f892fa76796891422611622fb143fefe94de51d14c996141216c1f7f1d58 SHA512 2e8c019a353d40438ef3cf4d20e1bc769fda2a0dd57e6c798ce5671e8733dc26e369c0b034ac9bea92641c2202c504bbef6617ddf2cfc7462ba8fc471398d462
MISC metadata.xml 251 BLAKE2B fa0c2c2679ffa3d7ee1d66435fa6ae0a87cd066936bef24881ca3c1559420ef9cb9aef9a8956f97d422a0b01ec5979674b4002f8d2141da8259c2e0ed049c506 SHA512 df914b4514c8649fb6ed3d115eb88866177d9cb8a9e4cfc743c28b7b1b17a32a4c3e5a5051f8f499089727ecce11dbe366f5065917795dc5f08f9524a499f676
diff --git a/dev-ml/yojson/yojson-1.7.0.ebuild b/dev-ml/yojson/yojson-1.7.0.ebuild
new file mode 100644
index 0000000..bc8be93
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.02.3:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ >=dev-ml/biniou-1.2:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ ~dev-ml/dune-1.11.4
+"
+
+src_install() {
+ opam_src_install
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}