summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2020-04-12 21:52:32 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2020-04-12 21:52:32 -0400
commit858621581a85a555ce1bfdc9813d15132742b615 (patch)
tree06f60f62b45174579e218bb0abd4bc495f6797f6 /dev-ml
parentadd 0install 2.15.1 (diff)
downloadsuperposition-858621581a85a555ce1bfdc9813d15132742b615.tar.gz
superposition-858621581a85a555ce1bfdc9813d15132742b615.tar.bz2
superposition-858621581a85a555ce1bfdc9813d15132742b615.zip
biniou and yojson also need to depend on dune
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/biniou/Manifest3
-rw-r--r--dev-ml/biniou/biniou-1.2.0.ebuild32
-rw-r--r--dev-ml/biniou/metadata.xml8
-rw-r--r--dev-ml/yojson/Manifest3
-rw-r--r--dev-ml/yojson/metadata.xml8
-rw-r--r--dev-ml/yojson/yojson-1.4.0.ebuild33
6 files changed, 87 insertions, 0 deletions
diff --git a/dev-ml/biniou/Manifest b/dev-ml/biniou/Manifest
new file mode 100644
index 0000000..56afb84
--- /dev/null
+++ b/dev-ml/biniou/Manifest
@@ -0,0 +1,3 @@
+DIST biniou-1.2.0.tar.gz 23611 BLAKE2B 01f5afada666d23b74f31cf12b5f578f3622c85311d7a1b6eb319843beac4c3ebe8e8e314a47ec14ee0ef6f5c1a5b6dd849dcf24b0c3cc8a38ca6a54d89e4c4d SHA512 04c04c2dd5e3e1237106db257567ba6900bd94759b07b02ba2e0d9209d1bbdc9ed629864e06d44a8b61f72d46fbcc7a0ffc86f82feb223d9d99ca41afc625fab
+EBUILD biniou-1.2.0.ebuild 733 BLAKE2B bca11d4883ce1f7c6cdd3f1bc248ef90b74a252bb64838eefb8b93e92daa4960bbfb28eb4c186348d4f2fef577addf4f33623b3719efcfda45571daabddec515 SHA512 f5d1d62d70840aaf2f8b00829d6f4dea4105e63c4caf5699999892bf5500b1dd3ec87a6353d7b0e9fcd3a964d052fc48fe4abdf1f5c126da6806952c767be45c
+MISC metadata.xml 246 BLAKE2B 293edb7a04720164c7fe980b83a53e65fa0537bf20ee28f065f980b1a474ff468f2b7c4adb14c80b691080a801bbbc9095cb24fa4102ce10d57b0ac47d67ffa7 SHA512 d922d11e07aa5d95318b09b38f66979151ae05272a7f202e87a03ebc7df9fd985468cfdac2188e04b27e31a69c03d63b59f2682374430ad3d0dbdc7c909a2e1c
diff --git a/dev-ml/biniou/biniou-1.2.0.ebuild b/dev-ml/biniou/biniou-1.2.0.ebuild
new file mode 100644
index 0000000..612cf15
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/mjambon/biniou"
+SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ ~dev-ml/dune-1.11.4
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/biniou/metadata.xml b/dev-ml/biniou/metadata.xml
new file mode 100644
index 0000000..7bfe73b
--- /dev/null
+++ b/dev-ml/biniou/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">mjambon/biniou</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
new file mode 100644
index 0000000..f046c2e
--- /dev/null
+++ b/dev-ml/yojson/Manifest
@@ -0,0 +1,3 @@
+DIST yojson-1.4.0.tar.gz 26197 BLAKE2B c7d1a9d47f448995b31cd7631f64dec29e65b1f141854092bfe186a58c28b96c5c7f246f7e4ab4563dfcd84776904d4af77bbcbdc4e149229fbde339bd92df9f SHA512 dc019ecf0387299282c3df9a548456d2529993241911a83acb14f2361ed14886e5ebebe415773b6bc718cb0b12a25529184f3b5b62c71b42960fbd62e1c63bf6
+EBUILD yojson-1.4.0.ebuild 687 BLAKE2B 6fc3c22e1993b303ff796d03330accba6ff66bad67a9327b49935d3971c67973fe99306564a0883e5ff81caf315ea022cfe5ca95289c470a4d095f208a3dab1d SHA512 1edfac963eb80e38d2ba9895737e4cd97f5b12ba357ff2e02819a406f6b60ff3f52109ce596e8e3935d0603faaaeb0bf901447f3ec961009b9453f5ee71b82bd
+MISC metadata.xml 251 BLAKE2B fa0c2c2679ffa3d7ee1d66435fa6ae0a87cd066936bef24881ca3c1559420ef9cb9aef9a8956f97d422a0b01ec5979674b4002f8d2141da8259c2e0ed049c506 SHA512 df914b4514c8649fb6ed3d115eb88866177d9cb8a9e4cfc743c28b7b1b17a32a4c3e5a5051f8f499089727ecce11dbe366f5065917795dc5f08f9524a499f676
diff --git a/dev-ml/yojson/metadata.xml b/dev-ml/yojson/metadata.xml
new file mode 100644
index 0000000..96ead41
--- /dev/null
+++ b/dev-ml/yojson/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">mjambon/yojson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/yojson/yojson-1.4.0.ebuild b/dev-ml/yojson/yojson-1.4.0.ebuild
new file mode 100644
index 0000000..3cd5540
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/mjambon/yojson"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ >=dev-ml/biniou-1.2:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ ~dev-ml/dune-1.11.4
+"
+
+src_install() {
+ opam_src_install
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}