summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2020-04-12 14:52:11 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2020-04-12 14:52:11 -0400
commit97e7086fad7acf1e16a6d89e16bf4d9b2d416506 (patch)
treefb997ae01003c56fe37312e64b7d7f459d770ed9 /dev-ml
parentadd jbuilder alternative dep dune-1 to packages (diff)
downloadsuperposition-97e7086fad7acf1e16a6d89e16bf4d9b2d416506.tar.gz
superposition-97e7086fad7acf1e16a6d89e16bf4d9b2d416506.tar.bz2
superposition-97e7086fad7acf1e16a6d89e16bf4d9b2d416506.zip
copy of the 1.11.4 ebuild as well
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dune/Manifest3
-rw-r--r--dev-ml/dune/dune-1.11.4.ebuild37
-rw-r--r--dev-ml/dune/metadata.xml8
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/dune/Manifest b/dev-ml/dune/Manifest
new file mode 100644
index 0000000..497c50c
--- /dev/null
+++ b/dev-ml/dune/Manifest
@@ -0,0 +1,3 @@
+DIST dune-1.11.4.tar.gz 849090 BLAKE2B 4dace2d998dd00dd8fd51fef6bf0048fd7d0c7941794b4c775f8a1a6c8f694af52ebae2bee17fb531b3f4332fe49167422508a91efcbda61f5420ffee7e89750 SHA512 0afd7ba4d66ba742b6485546d6b7e07096f38f516c12c4fc506a151b6fc97805859d736fee3a0a5dcf8008af0e2a678f1fe7286f6d0a941c999f7d3d5b9a9ccb
+EBUILD dune-1.11.4.ebuild 767 BLAKE2B 0cf0578ebc84eabf14623dfc78c1df49d02be6f377b9763978b793ee70c00b0f79b8186c0df8e2caa7ea2424a8f537d1b2ca8850709b498e000dadacc3eaf66b SHA512 7e1dc0b0524f9e0bd85e6bdd902f99dbb54567f07b8d9ccbed3768427b7f98179093c6ab531750ff0a2f831a3ec926c435fd91d1f220c8fda9beb60db341224b
+MISC metadata.xml 242 BLAKE2B cf769ef02b6c4a44259c41bd7d8a6ff26667ab728d194a15597388e9d7c651c0564b04e464dee09aea2a15e0086375444d2227171b6f7a0c5e62d85e7a27282c SHA512 8293ffa247118ebab6925fec47f3d66bfebde1d25b101c57458d11ffaead3a70cf1fe9f1ed6e028b6ff2c769047966fdd673aee0296fa8ccf91c02e005dfb41e
diff --git a/dev-ml/dune/dune-1.11.4.ebuild b/dev-ml/dune/dune-1.11.4.ebuild
new file mode 100644
index 0000000..ccf8f9e
--- /dev/null
+++ b/dev-ml/dune/dune-1.11.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}
+ !dev-ml/jbuilder"
+BDEPEND=""
+
+RESTRICT="test"
+
+src_configure() {
+ ocaml configure.ml --libdir "${EPREFIX}/usr/$(get_libdir)/ocaml" || die
+}
+
+src_compile() {
+ ocaml bootstrap.ml || die
+ ./boot.exe -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ default
+ mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF}
+ mv "${D}"/usr/man "${D}"/usr/share/man
+}
diff --git a/dev-ml/dune/metadata.xml b/dev-ml/dune/metadata.xml
new file mode 100644
index 0000000..4e0f053
--- /dev/null
+++ b/dev-ml/dune/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">ocaml/dune</remote-id>
+ </upstream>
+</pkgmetadata>