summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-02-25 08:43:47 -0500
committerPhilip Miess <Philip_Miess@yahoo.com>2017-02-25 08:43:47 -0500
commit27d8ee80c1383308265073c29a1f31af2acc46b6 (patch)
treeaab8d2fcaf92c060a023b5978b1a5e59aa492c0f /games-arcade
parentuse the original icon (diff)
downloadsuperposition-27d8ee80c1383308265073c29a1f31af2acc46b6.tar.gz
superposition-27d8ee80c1383308265073c29a1f31af2acc46b6.tar.bz2
superposition-27d8ee80c1383308265073c29a1f31af2acc46b6.zip
add tokitori
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/tokitori/tokitori-20130705.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/games-arcade/tokitori/tokitori-20130705.ebuild b/games-arcade/tokitori/tokitori-20130705.ebuild
new file mode 100644
index 0000000..554c42f
--- /dev/null
+++ b/games-arcade/tokitori/tokitori-20130705.ebuild
@@ -0,0 +1,75 @@
+EAPI="5"
+
+inherit base games unpacker-nixstaller
+
+MY_PN="${PN^^t}"
+MY_P="${MY_PN}_${PV:0:4}-${PV:4:2}-${PV:6:2}.sh"
+
+DESCRIPTION="Help a baby chicken save all the eggs."
+HOMEPAGE="http://www.tokitori.com/"
+SRC_URI="${MY_P}.sh"
+RESTRICT="fetch"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ media-libs/libsdl2
+ media-libs/openal
+ sys-libs/zlib
+"
+
+pkg_nofetch() {
+ ewarn
+ ewarn "Place ${A} to ${DISTDIR}"
+ ewarn
+}
+
+S="${WORKDIR}"
+
+DOCS=( "README.linux" )
+
+src_unpack() {
+ local arch=x86
+ use amd64 && arch=x86_64
+ nixstaller_unpack "instarchive_all" "instarchive_all_${arch}"
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+ local arch=x86
+ use amd64 && arch=x86_64
+
+ exeinto "${dir}"
+ insinto "${dir}"
+
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}"
+ games_make_wrapper "${PN}" "./${PN}" "${dir}"
+
+ newexe "${MY_PN}.bin.${arch}" "${PN}"
+ newicon "${MY_PN}.png" "${PN}.png"
+
+ doins -r \
+ "namespace.txt" \
+ "resourcecache.xml" \
+ "audio" \
+ "config" \
+ "cursors" \
+ "fx" \
+ "animdata" \
+ "credits" \
+ "ending" \
+ "input" \
+ "localization" \
+ "maps" \
+ "menu" \
+ "splash" \
+ "textures"
+
+ prepgamesdirs
+
+ base_src_install_docs
+}